0

I am running a nextcloud instance on Rocky Linux 8.4, on a small nvme SSD. I have added an Evo 860 to use as external storage, but I cannot get it to work: Nextcloud does recognize if I give the folder /mnt/Evo860/NextCloudStorage/data rwx for user and group and set the owner to apache (the user under which the webserver is running), but I always get the "Could not create folder" error message in the nextcloud frontend. If I create a folder from bash as the apache user, it works flawlessly. I tried to chown 777 -R data/ (and for every folder upwards to Evo860), but that changes nothing. I have no idea what else to try.

If I add a folder via nextcloud frontend on the nvme SSD, it works as well.

1 Answer 1

0

So either a restart helped, which I doubt, or SELinux was in the way. Following this guide, I executed the SELinux step and typed in the following command

chcon -t httpd_sys_rw_content_t /path/to/my/external/storage/ -R

Now it works.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .