2

My Windows 10 Pro (build: 19041.1110) PC has a weird network problem. POST request is not working. (That's all. Everything else is working.) I thought it was chrome, but every browser (Firefox, edge) shows the same problem. So, I hosted a php file and sent an ajax and I didn't get any POST data inside the php. The request is correct, the POST data, URL, etc. is all correct and the php works in other devices and also in my PC's dual boot ubuntu. The form data has data in it, but when I dump it in php $_POST is blank.

Not working: My php file, login pages (WordPress ,etc).

Working: Google login, lazy loading in well known sites, etc.

I have windows updates turned on.

A curl to my WordPress site returned nothing(no nonce check);

curl -d "action=contact_form_submission&formdata=name%Hohn%2520K%2520Nair%26tel%3D08301044114%26email%3DHohn%2540spz.com%26message%3DBODY&nonce=44f76c594d" -X POST https://www.mysite.de/wp-admin/admin-ajax.php

No output.

The network tab shows 0 as response for every post request (On network tab, the Form Data shows the formdata but $_POST in php seems to be empty). On my WordPress site, it gives 400 error and on a Laravel site it shows 422 Unprocessable Entity. enter image description here enter image description here

5
  • Can you show the output of cURL -vvv when you do a POST request in windows? Or if that's too much hassle maybe the output shown for the POST request in the network tab of your developer options in the browser? Aug 2, 2021 at 9:48
  • Can you edit your question to include the full curl command and its output? Aug 2, 2021 at 10:17
  • @SaaruLindestøkke Done Aug 2, 2021 at 10:25
  • I see you've not added the -vvv option to curl, so it doesn't print out verbose information which can help identify what's going wrong. Can you please edit your question? Aug 2, 2021 at 13:49
  • Nevermind, I tried it myself. curl -vvv -d "action=contact_form_submission&formdata=name%Hohn%2520K%2520Nair%26tel%3D08301044114%26email%3DHohn%2540spz.com%26message%3DBODY&nonce=44f76c594d" -X POST https://stage.centerplast.de/wp-admin/admin-ajax.php doesn't return anything out of the ordinary. It appears the POST goes through. Perhaps the content of the body is not as expected? Aug 2, 2021 at 13:54

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.