I have an HP LaserJet P1005 printer, attached to an Airport Extreme 802.11n wireless router's USB port. The Airport is set to share the printer by Bonjour, and my laptop can see the printer.

I'm running Mac OS X 10.6.4, and my HP printer driver version is (The latest version available via software update as of this date).

Sometimes (and yes, I know how useless 'sometimes' is in a bug report!) the printer will work -- this was true, for example, last week -- and other times (such as today) the printer is 'busy'. The printers' green status light is steady, but the print and fax preference pane shows the printer as busy, and I can't print anything to it.

I've cycled the power on the printer and deleted and re-added the printer, but this makes no difference.

What causes this? How can I fix it?


From Solution from CUPS author

I found this while researching my bonjour problem. It worked for me.

Re: Can't print after 10.5.2 install Posted: Feb 20, 2008 7:23 PM in response to: MTR300 Solved

The CUPS author created a small utility that should help with the 10.5.2 upgrade and the Airport problems:



  1. Add Airport printer
  2. Run FixAirportPrinter application
  3. Double-click on printer in list (or click on printer and click on "Fix Printer" button)
  • This seems to be working; I'll try it in a few days and see if it's still holding out. The problem is so erratic that it's hard to be sure that it's solved. – Chris R Aug 8 '10 at 4:29
  • @Chris R: If you intend accepting this answer, it would help to do so before the bounty date. The new bounty rules are really a pain. – harrymc Aug 9 '10 at 12:31
  • I'm going to do that, if it keeps working til then. It's been so erratic over the months I can't believe it's working. Do you know what this app does to the CUPS config? I couldn't suss out what it was up to. – Chris R Aug 9 '10 at 21:33
  • @Chris R: It's not documented. Apparently it sets straight problems caused by upgrading to newer version of OS X. – harrymc Aug 10 '10 at 6:07

Since the printer access is controlled by a router in this case, I would try connecting it directly to the computer, just to check if the router is the culprit.

Other possible options:

  • Driver problem. Latest driver does not always mean the best driver. Sometimes, bugfixes might introduce new bugs. If you have the possibility to try an older version, one that came on a CD with the printer, that may help to exclude the driver as the culprit.
  • This has occurred with several generations of the driver, starting with the one that came with the printer, all the way to the current incarnation. It's got to be software, because the Windows netbook my wife uses can print to it, when it can see the printer (which is another issue entirely) – Chris R Aug 5 '10 at 3:23
  • Software or hardware... Since you have an another issue in Windows, I would suggest connecting the printer directly to any of your computers. – TFM Aug 5 '10 at 7:31

Is the Airport running the latest firmware? Older Airports running outdated firmware can cause interesting issues.

  • According to Software Update, yes. – Chris R Aug 5 '10 at 3:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.