Motherboard: gigabyte B450M S2H V2 (new)

CPU: Ryzen 7 3700x (new)

RAM: 2x16 GB DDR4 UDIMM - mta18asf2g72pdz-2g3b1ig (used from a reputable seller)

Tried two different PSUs (tested both on an old system first and that seemed to POST fine) got fan spin and no beeps (mostly, see next paragraph) but when I tried to plug in a graphics card I got no graphics output (the graphics card seem to work in a different system). Removing either of or both RAM sticks didn't seem to change anything, still no beep codes, removing the CPU power cable (the 4 pin connector) also didn't change anything.

Got something that sounded a bit like a beep from the PC speaker once but couldn't replicate that. Tried a different speaker in case there was an issue with that but it didn't seem to help.

Does the fact I don't get beep codes even when in a clearly invalid state (no RAM or no CPU power) indicate the motherboard is failed? Or are beep codes handled by code running on the CPU? I can't test the CPU or RAM on another motherboard as I don't own any motherboard with an AM4 socket or that uses DDR4 memory.

Could the power supply be faulty in some way that lets it boot older systems that might have higher tolerances but cause failures in newer hardware?

Edit: Turns out I was sold RDIMM memory as UDIMM, not sure why it didn't result in beep codes but when I got some UDIMM memory the system booted.

  • 1
    Most mobos don't have a beep speaker attached these days, just a header where you can add your own. Some have lights instead. Found it - on GB's site for the mobo - i.stack.imgur.com/zKgsD.png
    – Tetsujin
    Aug 5, 2021 at 14:00
  • yeah I attached an old speaker I had, it made some sort of noise initially but it wasn't very clear, tried a different speaker later and got nothing.
    – Eryk
    Aug 5, 2021 at 14:09
  • Does your power supply meet all of the requirements of the motherboard? Did you plug in all of the required power connectors. Is this a new build? If so, it's possible that you didn't seat the processor properly. If you didn't use proper grounding techniques when installing the processor, it could have damaged the processor.
    – user09938
    Aug 5, 2021 at 14:21
  • it should, tried a 500 and then a 330 watt power supply, and the CPU is a 65 watt part and PCI-E can only supply up to 75 watts for the graphics card. As for grounding I did touch the power supply case which should be grounded unless the manufacture is trying to kill its customers. I tried re-seating the CPU but it's one of those zero force sockets so I'm not sure if it can even be seated wrong?
    – Eryk
    Aug 5, 2021 at 14:46
  • All 3 fail at once, unlikely.
    – Moab
    Aug 5, 2021 at 18:12

1 Answer 1


According to multiple searches on the internet, you have the following RAM:

MICRON 16GB PC4-2400T-R Registered ECC

This wont work with your current motherboard as it is registered and error correcting RAM. You need unbuffered, non error correcting RAM. If you want to be 100% sure, you can check the Memory Support List for your motherboard on the gigabyte website.

  • Huh you are right, the seller was selling it as unbranded UDIMM but it does say that on the label. Is there any way to tell by visual inspection if the RAM is registered or unregistered? Either the seller made a mistake or there is something weird going on with the numbers.
    – Eryk
    Aug 6, 2021 at 10:42
  • I will test some different memory if I can get my hands on it
    – Eryk
    Aug 6, 2021 at 10:43
  • Registered ECC ram will show something like PC4-2400-RE on the sticker and you will typically have 9 little ram banks on it instead of 8. The seller likely made a mistake, but the part number defo comes back as registered ecc.
    – Silbee
    Aug 6, 2021 at 10:46
  • Yep it has 9 banks! I'll test this and then likely mark this as the correct answer.
    – Eryk
    Aug 6, 2021 at 10:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .