0

I have a laptop with two drives :

  • small SSD (with windows)
  • HDD (half linux, half data) I wanted to replace the HDD with a new SSD (samsung evo) with the same size. So I cloned everything to the new SSD but it didn't want to boot on it. I have a black screen

So I tried something else:

  1. I deleted grub to boot directly in windows
  2. I formatted the new SSD in ntfs
  3. I replaced the old HDD by the new SSD (empty)

Now I have a black screen again on boot, I cannot even access to the BIOS

I checked everything :

the sata cable works fine, If I plug the old HDD it works fine

the SSD works fine, I tried it thanks to sata -> USB cable. I even tried to install a system on it and I could boot on it through the usb port.

If I just remove the disk (so there's only the small ssd with windows), it works and it boots on windows

So I was thinking maybe it was due to the alimentation but again I don't understand how it could be possible. Both are 5V and normally, a SSD should consume less power than HDD.

Does anyone know how I could fix this problem ?

Thanks!

1
  • Sorry, I thought I said hello but I didn't. So Hello everyone !
    – Kasmir
    Aug 6, 2021 at 8:17

2 Answers 2

0

Such a problem can occur if the new drive is specified at an different SATA level than the old one it should replace. If your laptop is designed for SATA 2 or 2.6, a drive for SATA 3 will not work in any case.

Samsung EVO claims to be compatible with SATA 2 or 2.6. I have verified it on a single laptop here. Perhaps this compatibility is not given in any case. Please verify this.

3
  • I found the reference of the old HDD. inmac-wstore.com/wd-blue-wd10spzx-disque-dur-1-to-sata-6gb-s/… // it says that it has a sata-600 interface which correspond to 600mb/s. This rate is the one of SATA III
    – Kasmir
    Aug 6, 2021 at 8:49
  • Also my computer is 3 years old, that would be weird to use SATA II.
    – Kasmir
    Aug 6, 2021 at 8:53
  • i.imgur.com/TASKPQo.png so it's SATA 6
    – Kasmir
    Aug 6, 2021 at 9:09
0

I found the problem. Since BIOS update 1.04, the system doesn't allow to add an SSD with more than 512GB through SATA interface. https://community.acer.com/en/discussion/comment/674891/#Comment_674891

Since M.2 also use SATA, those are also concerned by this, you'll need a PCIE interface (nVME drives) to bypass this limitation

From here you have 2 solutions if you don't have any PCIe interface:

  • buy an SSD with less than 512GB
  • downgrade your BIOS to v1.03 (with all the risks involved)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .