17

I seem to have a problem with my local Vim configuration but I'm not sure what it is. I need to override some filetype-specific settings. As per multiple tutorials/howtos, I created ~/.vim/after/ftplugin/cpp.vim with appropriate setlocal statements, but it seems not to be read. I checked that ~/.vim/after is in runtimepath.

I worked around this with autocmd FileType cpp setlocal ... in ~/.vimrc, but that is beyond the point. Any advice on how to diagnose/fix this? Or am I just overlooking something obvious?

18

Check the output of:

:filetype

You may need to add

filetype plugin on

to your .vimrc (or at least add 'plugin' to your 'filetype' setting).

9

A good place to start would be to use the :scriptnames command. Open a C++ file however you normally do and execute

:scriptnames

This will show you the files that Vim has sourced since it was started.

  • 1
    That's a useful tip for debugging. I used to run vim --cmd 'set verbose=2' in order to see which script files were being sourced. – Anthony Geoghegan Nov 24 '16 at 15:42
  • Yes, very useful. I learned that, the load-order of after-plugins is not what you would think, see answer vi.stackexchange.com/a/20227/20753 about that. – Jari Turkia Jun 6 at 6:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.