1

I've got this problem: There is a server running "Ubuntu 20.04.1 LTS" and a JDK 8 application. The machine has 256GB of memory, but when I run

java -XshowSettings:vm

on that machine, it says

Max. Heap Size (Estimated): 26.67G

Currently the JVM is started with the arguments -Xms25g -Xmx25g, however I want the JVM to use 32g or even more.

How can I tell Ubuntu to give more memory to a JVM instance?

The question is based on the fact that if I start the JVM with -Xms32g -Xmx32g it crashes after startup, with 25gb it doesn't.

The JVM wrote an error dump, starting with

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fe590e47acb, pid=778060, tid=0x00007fdd5d090700
#
# JRE version: OpenJDK Runtime Environment (8.0_282-b08) (build 1.8.0_282-8u282-b08-0ubuntu1~20.04-b08)
# Java VM: OpenJDK 64-Bit Server VM (25.282-b08 mixed mode linux-amd64 )
# Problematic frame:
# V  [libjvm.so+0x87dacb]
...

Otherwise there is no exception or error written in any logs I checked.

2
  • 1
    How much memory does the host have total, and have you tried setting the JVM to start with 25G heap size with upper limit o f 32G ie -Xms25g -Xmx32g and seeing how it behaves?
    – Josh Zhang
    Aug 12, 2021 at 14:53
  • @JoshZhang as I wrote at the beginning, the host has a total of 256GB memory. I haven't trid to start with less memory, my target is to get over 32g actually.
    – bzero
    Sep 22, 2021 at 12:58

0

You must log in to answer this question.

Browse other questions tagged .