When I click on a link, it starts Zoom, but Zoom just hangs on connecting. After a few minutes it gets an error that it's unable to connect. Says Check to make sure you are connected to a stable network that is not blocked by a firewall or proxy. Here is what I have tried.

Tested on different internet connection and same issue, Reinstalled Zoom, Installed older version of Zoom, Verified Zoom has camera, microphone and accessibility rights checked, Camera and microphone work, Internet works for everything else, Scanned for viruses and spyware with Malwarebytes and was clean, Does not have any Antivirus or Firewall software installed.

Any suggestions would be great because I am out of ideas.

4 Answers 4


I had uninstalled Zoom by moving the zoom app in Applications to the trash. I ended up opening Zoom and doing an actual uninstall and then reinstalling and now the permissions seem to be working and it does not hang on connecting

  • This is the trick that worked for me. I also restarted my Mac after (a) uninstall Zoom from the Zoom app and (b) reinstall the app. Oct 13, 2021 at 20:19

Getting to the bottom of an application error can often take time. It's great you've already gone through some troubleshooting steps (helps those trying to assist you!). I'd recommend however pasting the exact error message zoom is giving into your question. Usually when an application errors out, there is also an error code. This can greatly help in diagnosing your issue. Here are some of my suggestions on what you could do next based on the information provided:

1. Restart your computer

I am assuming you have already done this, but half my problems on computers have been solved by restarting. I cannot tell you how many times I've told people to simply restart and everything is fixed. If you need any help on this, I found the Apple help page for this.

2. Permissions and Other Settings

You have probably already seen this page by AppleToolBox which outlines a bunch of permissions and other network settings you can change (alternatively look take a look here). In fact, it looks like you've already gone through most of it. It's worth double checking however as sometimes in these situations I've realized I forgot a step after hours of troubleshooting.

3. The Zoom Link

The issue could also lie in the zoom link you are using. Which application does it error from? All applications or just a few? Have you tried manually inputting the zoom ID into zoom and joining that way? For instance:


The 5551112222 is the zoom ID that you could enter into Zoom. To enter this, click the Join button in the Zoom application. Sometimes there is also a password. This is sometimes in the link following the ID.

Finally, perhaps try different Zoom links. You could create Zoom meeting yourself and join your own meeting by pasting the link into the application you're having trouble with and then clicking it.

4. Update your macOS version

You mention you are running macOS Catalina. The current version is Big Sur. This could possibly be part of the problem. Theoretically, Zoom should support Catalina as they state Zoom works all the way back to macOS 10.14. There is always the chance they haven't fixed something on an older version.


Best of luck figuring out your problem. I would recommend seeing if you can find the error code zoom is giving you. Post it here as that will assist people helping you. I found a Zoom page with common error codes. The post here also outlines other resources to help you on your way. As a last resort, you could also contact Zoom Support.

  • 1
    So there is no error number. The exact error is as follows: Unable to Connect. Check to make sure you're connected to a stable network that is not blocked by a firewall or proxy. Then there is an OK button, but no error number. I will upgrade to Big Sur and see what happens, seems like a logical next step. Thanks for the help.
    – drnet
    Aug 26, 2021 at 21:22

Adding onto the answer from drnet, I finally resolved this by following his answer. In case anyone else hits this issue in the future, these are the exact steps to do the uninstall they suggested.

Go to Applications -> right clicking on zoom.us -> Show package contents -> open Contents -> open Frameworks -> use the ZoomUninstaller file.

After this, I reinstalled and it successfully worked.


I tried all of the above, and in the end, I found that I had to remove all DNS configuration. Try this if you're like me and have

  1. Uninstalled
  2. Restarted
  3. Cleared all Proxy settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.