0

Like said in the long title, I can't access my site hosted on AWS with AWS Route 53 Hosted Zone. When I initially configured my DNS, there may have been something wrong with the A records which resulted in a server not found. I updated my DNS configuration and my laptop still cannot access it.

However, the updated DNS configuration is correct such that when I use a different laptop or use my friends' phones (some tested at my home using my WiFi and others tested at their own home with their own WiFi; all of them worked for my friends regardless of the device), it works fine. When I do an nslookup from my laptop, it says ** server can't find hearye.us: SERVFAIL. But when my laptop (a MacBook Air) is connected to my phone's personal hotspot, it works fine.

I tried changing wifi networks (two completely different wifi networks at two different locations) to no avail. I also tried flushing my DNS cache using this: sudo dscacheutil -flushcache; sudo killall -HUP mDNSResponder.

Also note, I tried testing this on my iPhone 6s during the incorrect DNS configuration. So my iPhone 6s has the exact same problem. If it's on WiFi, it fails, regardless of which WiFi. If I use my cell data/network, it works fine. Hence, when my laptop was connected to my phone's personal hotspot, it connected since my phone was using cell data.

I also ran this but didn't receive any A records:

> dig hearye.us A

; <<>> DiG 9.10.6 <<>> hearye.us A
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 59936
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
; OPT=15: 00 06 ("..")
;; QUESTION SECTION:
;hearye.us.         IN  A

;; Query time: 49 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Sun Aug 29 08:39:20 EDT 2021
;; MSG SIZE  rcvd: 44

But if I were to use trace to search for A records:

> dig +trace hearye.us A                                                     

; <<>> DiG 9.10.6 <<>> +trace hearye.us A
;; global options: +cmd
.           478995  IN  NS  f.root-servers.net.
.           478995  IN  NS  j.root-servers.net.
.           478995  IN  NS  h.root-servers.net.
.           478995  IN  NS  i.root-servers.net.
.           478995  IN  NS  l.root-servers.net.
.           478995  IN  NS  g.root-servers.net.
.           478995  IN  NS  c.root-servers.net.
.           478995  IN  NS  m.root-servers.net.
.           478995  IN  NS  d.root-servers.net.
.           478995  IN  NS  a.root-servers.net.
.           478995  IN  NS  e.root-servers.net.
.           478995  IN  NS  b.root-servers.net.
.           478995  IN  NS  k.root-servers.net.
.           478995  IN  RRSIG   NS 8 0 518400 20210910170000 20210828160000 26838 . LEbxKWIHGPcaP4+O2SYenMrlF5dLDFGD579aeUCz2h+0U5kvuWPNy9OL RVACqWliE2FbvXDzl8dNGHyTYNt5n9fDDbyrsxZTBfDEGs9sl1dk4hGa QXnu3jC2Em0Ngk4DB7kAulKoENMUtejIDCq6sWE8NnbipNF2pSkR7u8C GQsqO9j83DNB4DAsnMPjtiQ0TpgriuvI5MRJpzmvfIkoZDIi+65bdQ5v HR0zzkR9wdb3KFJ5pgHdsg6KZM+1//PMEEN0C6MCWng71gMMv1lpr8Y6 oCMPOqZ+zvht+Zjba/eVEZlhdFuXgYG/4DnpGp0wWSYu+WK3x/RStabh efs9jQ==
;; Received 1097 bytes from 192.168.1.1#53(192.168.1.1) in 61 ms

us.         172800  IN  NS  b.cctld.us.
us.         172800  IN  NS  f.cctld.us.
us.         172800  IN  NS  k.cctld.us.
us.         172800  IN  NS  w.cctld.us.
us.         172800  IN  NS  x.cctld.us.
us.         172800  IN  NS  y.cctld.us.
us.         86400   IN  DS  21364 8 1 260D0461242BCF8F05473A08B05ED01E6FA59B9C
us.         86400   IN  DS  21364 8 2 B499CFA7B54D25FDE1E6FE93076FB013DAA664DA1F26585324740A1E 6EBDAB26
us.         86400   IN  RRSIG   DS 8 1 86400 20210911050000 20210829040000 26838 . U+O6W4/v+GM1UkuWyJPxR2HNvzTQoaKFtqfB99GVFhihtcTf4qQ13zNo MfXKNO/xc4fGdCeo3tOlOaZap8lcACIJ+4HfwoCFr6hxYzWfn1PpAMTs jP/IUofGd+0meJOk4pkhMDJYfNUrRvwKpFVc33JsSSGpLrQDxpo8akC7 p7/wc6sWe0I2vgF28XvgbplTpcW1zSB9pQxenpqNl4Tc0BYHipEAGXF3 Kfn6IleJk32aVmhPoQXdR2dxOVRPWzixbtS0fyzf5vs2a1JMM2tpokSo njJTMoG1bswtd6bxPJXD+nk0lLG4X86/SIR1Ld4QhchXbJmhifDFSDic Mmp9Bw==
;; Received 775 bytes from 192.203.230.10#53(e.root-servers.net) in 16 ms

hearye.us.      3600    IN  NS  ns-1812.awsdns-34.co.uk.
hearye.us.      3600    IN  NS  ns-1303.awsdns-34.org.
hearye.us.      3600    IN  NS  ns-487.awsdns-60.com.
hearye.us.      3600    IN  NS  ns-575.awsdns-07.net.
hearye.us.      3600    IN  DS  61364 8 2 68864D596CF36E3D218294FC22053069F5E274C732894912AAFC9F5F 3D4E890C
hearye.us.      3600    IN  RRSIG   DS 8 2 3600 20210922233703 20210823223703 53985 us. c92Hbw7hiuvdQ0tx28vws9Yj3DT9g/vlFCrqu5f+Vo+TzIxM2aW8i8qT flYD086RmuPm6e+aekb6vAOZrRLNhr87ziyosUOfrJVWPHjoZC639fDC 44aJ5KOMWHvDqJQrpmHmVGkTzPmtOlABV+ydZ44M1ikIzLRojQmGsqPe 7nHDrdf8pUjVywvgblfhr9A/40TjuOME8wu7tTgTJM/zag==
;; Received 420 bytes from 37.209.196.15#53(y.cctld.us) in 18 ms

hearye.us.      60  IN  A   3.13.0.198
hearye.us.      60  IN  A   52.14.70.205
hearye.us.      60  IN  A   3.130.110.201
hearye.us.      172800  IN  NS  ns-1303.awsdns-34.org.
hearye.us.      172800  IN  NS  ns-1812.awsdns-34.co.uk.
hearye.us.      172800  IN  NS  ns-487.awsdns-60.com.
hearye.us.      172800  IN  NS  ns-575.awsdns-07.net.
;; Received 226 bytes from 205.251.197.23#53(ns-1303.awsdns-34.org) in 33 ms

Now, I actually don't understand what dig does; I just found it online. Explanation is not needed since I'll try to learn it myself unless it relates to the problem.

I also went to the public IP address you see in the A record, and the website (a default nginx page that I didn't bother unlinking) loads just fine.

Finally, restarting, shutting down, etc. (not really willing to factory reset) my laptop or phone does not work.

Any guesses as to what could be the problem and/or how to resolve?

1 Answer 1

0

Try these, https://linuxize.com/post/how-to-clear-the-dns-cache/

You may have separate DNS tables in your

  1. Browser,
  2. OS,
  3. Router,
  4. ISP,
  5. DNS Server,
  • Most will automatically update after 24h.
1
  • It's been 3 weeks, so not router, ISP, or DNS server (since I keep moving to different locations). I also tried clearing everything in the browser, but doesn't work. I had already done the commands from the link (as noted in the question). Same with the command line. Thanks for trying tho.
    – acw
    Sep 6, 2021 at 15:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .