12

Like many other users I'm trying to disable this new feature that goes by different names (Modern Standby / Connected Standby / Always on always connected / S0ix / InstantGo / ...) as it has lots of drawbacks and hardly any advantage:

  • drains way more power than S3, which apart from the unnecesary energy waste, can make a laptop turn off and cause loss of data and/or loss of unsaved work
  • as the system is not in standby but instead it's still active (sometimes you can even hear the fan!), if you put the laptop inside a bag it can severely overheat
  • S0ix states are non-standard
  • security problems: for example a laptop inside a bag connecting to rogue wifi APs
  • Windows Update can reboot the system while it is "suspended" causing loss of unsaved work

There are already a few answers in this site or others, but they don't work on my HP 250 G8 laptop (the answers are partially manufacturer-specific as they all have their own Modern Standby implementation):

  • set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\CsEnabled to 0 (REG_DWORD): Microsoft removed this, and it does not work in any system anymore
  • set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PlatformAoAcOverride to 0 (REG_DWORD): this still works for some people but in my case it just removes the Modern Standby option, but does not bring back S3 mode

Some answers say that manufacturers may have completely removed the S3 code from the BIOS, but I tried booting Linux on this same laptop and it goes to S3 mode with no problem

Is there any specific tweak for HP systems for this? Or a universal one apart from the mentioned CsEnabled and PlatformAoAcOverride registry keys?

EDIT:

Adding powercfg /a output (in Spanish but it can be seen that only Hibernation is available)

Los siguientes estados de suspensión están disponibles en este sistema:
    Hibernar

Los siguientes estados de suspensión no están disponibles en este sistema:
    Modo de espera (S1)
        El firmware del sistema no admite este estado de espera.

    Modo de espera (S2)
        El firmware del sistema no admite este estado de espera.

    Modo de espera (S3)
        El firmware del sistema no admite este estado de espera.

    Modo de espera (inactivo de baja energía S0)
        El firmware del sistema no admite este estado de espera.

    Suspensión híbrida
        El modo de espera (S3) no está disponible.

    Inicio rápido
        Esta acción se deshabilita en la directiva actual del sistema.

Other info:

  • Win10 Pro 64bit 21H1
  • I checked every option in the BIOS but there is nothing related to that
  • Hibernation works fine
  • Tried with Fast Boot enabled and disabled
8
  • What's the output of powercfg /a? What happens if you try to manually put it in sleep or hibernation (according to the wiki that shouldn't work)? Did you check whenever there are related settings in the BIOS? Did you check the regular energy management options? What version of Windows 10 are you running?
    – Seth
    Aug 30, 2021 at 12:06
  • @Seth I edited the question. About manually putting it in sleep, I can't either from Windows start menu, Alt+F4 at the desktop, or from Process Explorer, the option is not there anymore
    – golimar
    Aug 30, 2021 at 12:23
  • My guess would be you're not able to use it but got rid of Modern Standby. Microsoft: Modern Standby FAQs. Is there a problem with using Hibernation? It looks like there are some UEFI patches but those might easily brick your system.
    – Seth
    Aug 30, 2021 at 12:48
  • 2
    Ideally I want Suspend for short periods and Hibernation for long ones, but anyway I'll resort to Hibernation. One has to accept the "tabletization/smartphonization" of PCs...
    – golimar
    Aug 30, 2021 at 13:03
  • Modern Standby is implemented via a new S0 power state, but your powercfg output explicitly states that S0 is disabled. Did you run powercfg when you had PlatformAoAcOverride = 0?
    – Ian Kemp
    Oct 7, 2021 at 8:29

0

You must log in to answer this question.

Browse other questions tagged .