2

I'm trying to install Solaris 10to a computer without an optical CD/DVD/Blu-ray drive.

Here is what I have now:

  1. Solaris 10 ISO got from the sun site (grub installed).
  2. A running ArchLinux x86_64 installation.
  3. A running Windows 7 x86 installation with Cygwin (Though I guess it may be not that useful?)

And here is what I have tried but failed:

  1. unetbootin (a tool that write Linux ISO’s to a USB flash drive, Solaris is not on its support list). After boot from the USB drive, I got some “corrupted kernel” error from the GRUB.
  2. Manually extract files from ISO to vfat-formatted USB flash disk, and try to install GRUB (0.97) on it under Linux. But GRUB says some “bad stage1/stage2” stuff.

Did someone succeed such thing? I mean, write the content of ISO to USB disk, and install Solaris using it.

Hints/tips/advices are also welcome.

1

After having a lot of failures with unetbootin (I haven't the foggiest why people still recommend it), I found that with some work you can actually does this pretty easily.

You'll need a program capable of exactly copying a partition or drive, bit for bit, including the Master Boot Record. Some are included with Windows that supposedly work, I use a complicated VMWare method, and there are plenty of others (free and not) available. Just Google "disk drive cloners" (sorry, I don't have any recommendations).

You'll also need a program capable of mounting an ISO as a disc drive. Daemon Tools Lite (an early version without ads) works perfectly.

All you need to do is mount the disc image as a drive and clone that drive/partition to your flash drive. Works perfectly most of the time and is lightning fast (not as fast as unetbootin, but then again, it works).

I've tested the method on Windows, DOS, Ubuntu, Puppy Linux, GPartEd and CloneZilla, and Mac OS X. Worked great on all of them. As long as your system can boot from USB, it should work. There may be issues if it isn't capable of reading a CD filesystem in the BIOS, but if the BIOS can boot from CD and USB (but no CD hardware exists), you should still be fine.

However, you may want to check and make sure your Solaris image is valid. A corrupt kernel error is often the result of a bad disc image. It's not a big deal on flash drives you can re-write, but if nothing works and you keep getting the error, double-check the image.

0

I would say that this would work, I have seen it work on a couple of Linux distros. Here are Linux Instructions (not sure for what distro exactly, I dont do much with Linux), and here are Windows Instructions.

They seem to be simple generic ISO to Flash Drive programs, so its basically the same as writing it to a CD. Cant say I've ever tried it with Solaris though.

0

Rufus to make bootable USB's from ISO's. I think it was written by someone just as frustrated with ISO=->USB creation as you are at the moment.

enter image description here In my own experiencs when UNETBOOTIN failed, it was always Rufus that worked and became my sole bootable ISO --> USB maker.

It's fast, it formats the USB drive for you and it has superb boot loader detection and also self updates itself or just versions of Syslinux if it detects a possible incompatibility.

enter image description here

protected by JakeGould Dec 5 '17 at 0:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.