0

I'm using Linux Ubuntu 20.04 with HWE. I have two HDDs installed and those never go to sleep even if their usage is none for 5+ minutes (that's the setting in gnome Disks manager).

This used to work some time ago, but now doesn't seem to. If I manually put both disks to sleep, those stay as such for hours, so not quite sure what's preventing this from happening.

How can I find this out?

Thanks!

Edit

fuser and/or lsof don't report of any file open on those mounts (i.e. /disk2 and /disk6) - I've set the timer to 5 minutes, from 10 and I'll report what happens.

22
  • Check out this post for possible causes.
    – harrymc
    Sep 4 at 16:40
  • my smartd should be setup with default values (30 mins) and my disks are supposed to shutdown in 5 minutes of not being active. Checked the -B option and those don't support APM, not sure how to check -S via command line, but via Ubuntu UI it's 5 minutes... so not sure what's the issue.
    – Emanuele
    Sep 4 at 22:38
  • Does this happen if you just disable smartd?
    – harrymc
    Sep 5 at 8:35
  • I issued sudo smartd stop and waited approx 3 hours. The disks are still active/idle. Should I have used another command to stop smartd?
    – Emanuele
    Sep 5 at 16:12
  • Try service smartd stop.
    – harrymc
    Sep 5 at 16:42
1

Apart monitoring the filesystem with obvious tools such as fuser and lsof, the only tool which actually reports every activity is auditd (installing then issuing sudo auditctl -w /dev/sda -p rwa and then searching the logs with sudo ausearch -f /dev/sda).

With this powerful tool, one is able to clearly identify what is interacting with the given device (/dev/sda in this example) and then take appropriate actions.

In my case it's the combination of having a couple of WD disks which apparently don't play nice with with standby command and are woken up by the udisks2/udisksd daemon invoking the smart report command every 10 minutes (it shouldn't wake up the disk - or better preventing from standby-ing but it does with those WD here and here for more details).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.