0

After some time of use hours or days dns request suddenly stop to work and timeout. Changing DNS server does nothing as it timeout on any of them ( tried ISP DNS, google, opendns all the same ). At the same time all other internet connection seems to work. E.g. I can ping I can use telegram just DNS not working.

Turning off firewall does nothing, have only windows firewall. It started to happen when I switched from lan cable to asus ax-58bt PCI wifi card. Plugging back LAN cable after this happened ( e.g. when dns stopped to work) dont do anything too and it still not working. Only restart of pc work to fix it till it happens again. Not sure where to look at next any ideas ?

Tried with buildin driver and driver from asus site for pcie card, all same. And it wasnt happening purely on lan cable.

Windows 11

UPD in event viewer probable reason, but not yet figured cause

A request to allocate an ephemeral port number from the global UDP port space has failed due to all such ports being in use.

UPD2 that event dont seem to be the cause. Happened today and i checked allocated ports with

netstat -anob -p UDP

And there was not a lot of them, like less than 50 and certainly was opened.

Tried to stop dnscache service ( as admin) but

net stop dnscache The requested pause, continue, or stop is not valid for this service.

In services list stop and restart also disabled. Tried to kill by process id from dnscache from netstat -> it was successfull e.g. it killed but than automatically started again, but dns still wasnt working.

Ipconfig when it happens:

ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : DESKTOP-1T4683A
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : stampinup.com

Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) I211 Gigabit Network Connection
   Physical Address. . . . . . . . . : 60-45-CB-9E-09-94
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Ethernet 5:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : TAP-Surfshark Windows Adapter V9
   Physical Address. . . . . . . . . : 00-FF-AF-E0-76-99
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Unknown adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : TAP-Windows Adapter V9
   Physical Address. . . . . . . . . : 00-FF-9E-9E-91-55
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 10:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #2
   Physical Address. . . . . . . . . : 6A-54-5A-CB-67-7C
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter WiFi:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Wi-Fi 6 AX200 160MHz
   Physical Address. . . . . . . . . : 68-54-5A-CB-67-7C
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.1.5(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 3 сентября 2021 г. 18:55:19
   Lease Expires . . . . . . . . . . : 4 сентября 2021 г. 18:55:19
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 208.67.220.220
                                       8.8.4.4
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter vEthernet (Default Switch):

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Hyper-V Virtual Ethernet Adapter
   Physical Address. . . . . . . . . : 00-15-5D-0A-A2-00
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 172.26.144.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.240.0
   Default Gateway . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled

In event viewer dont see anything other that could be cause and only happens before this situation.

UPD it seems to happen after pc inactivity for hour or so, when it resume it work. But as i remember first time it was without this, so might be just more often after resume but not solely

12
  • 1
    (1) When this happens, run ipconfig and add the output to your post, then try in the Services applet to restart the DNS Client service. (2) Check the Event Viewer for something related. (3) Which version of Windows? (4) Try a lower value for MaxCacheTTL
    – harrymc
    Sep 2 '21 at 19:32
  • @harrymc thanks, will add when this happens again. re 4 - dont think it will do anything as its about caching, while my issue that dns request timeout via nslookup or anything, so its not cached.
    – Aldarund
    Sep 2 '21 at 20:31
  • @harrymc thanks for remidning about 2. seems i found why it happens but not what cause it, will investigate further > A request to allocate an ephemeral port number from the global UDP port space has failed due to all such ports being in use. superuser.com/questions/590686/…
    – Aldarund
    Sep 2 '21 at 20:43
  • Is then this question a duplicate of the linked post?
    – harrymc
    Sep 3 '21 at 9:40
  • @harrymc nope, i updated question with more info. when that happens port not really allocated
    – Aldarund
    Sep 3 '21 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.