6

Each morning I open my Windows 10 computer to a File Explorer with Google Drive listed to Quick Access -

          enter image description here

I don't want this there and remove it, each day to see it return the next. Is there any way to stop this daily auto-population?

My Setup:

  • Win10 Pro v21H1
  • Google Drive v51.0.9.9
4
  • 1
    Disable Show recently used files in Quick access and Show frequently used folders in Quick Access within Folder Options. If it still comes back then the option is within Google Drive.
    – Ramhound
    Sep 9, 2021 at 5:26
  • 2
    Thanks @Ramhound, yep these are both disabled. I will reach out to Google next, this option doesn't appear available
    – J-Dizzle
    Sep 9, 2021 at 6:12
  • 1
    For reference, I have posted here we shall see - support.google.com/accounts/thread/125787417/…
    – J-Dizzle
    Sep 14, 2021 at 7:20
  • I didn't want to implement any of the solutions suggested, but I found a compromise I was pretty happy with. Apparently, Windows folder options allows you to hide the This PC section. All Drive folders are redundantly shown down in it. I pinned all the This PC folders to Quick Access, then moved them above the forced Drive pins. This view effectively emulates the configuration before Google forced the unremoved pinned Drives. It is far less distracting this way.
    – MXMLLN
    Apr 25 at 19:04

4 Answers 4

3

Open Google Drive Preferences → Settings. Uncheck the option Show Google Drive in Quick Access in File Explorer."

Src: How to Add Google Drive to Explorer Navigation Pane

This option seems to have been added in the latest (August 2022) Google Drive update.

3

If you go the preferences menu for the Google Drive desktop application, you will see information on what folders are being backed up.

But if you click the gear icon at the top right of that screen, it will take you to a settings page where you can uncheck "Show Google Drive in Quick Access".

I'm not sure why there are two levels of settings/preferences, but this should fix the problem.

2
  • 1
    Oh nice! This appears to be a brand-new option, thanks for sharing.
    – brichins
    May 27 at 16:49
  • 1
    Yeah, I was surprised to find it too!
    – inavda
    May 28 at 21:56
2

Here's a slightly less involved option, from this Reddit post, as there is still no support for configuring this in the app.

Hiding the Quick Access shortcut:

  1. Right click the Drive shortcut under Quick Access and unpin it;

  2. Navigate to %APPDATA%\Microsoft\Windows\Recent\AutomaticDestinations (This folder is hidden even if you have Hidden Items enabled, so copy this address and paste it in the File Explorer's address bar directly);

  3. Locate the file that starts with "f01" (full name: f01b4d95cf55d32a.automaticDestinations-ms)

  4. Right click that file and go to Properties, then go to the Security tab, and click the Edit button to change permissions;

  5. At the top half of the window, under "group or user names", highlight "Administrators". At the bottom half of the window check "deny" next to the Write permissions. Press OK to close all windows.

The f01 file is where windows stores the Quick Access list. By denying write access to it, the Drive app (and anything else) won't have the proper permissions to add the shortcut to the Quick Access menu and thus fails in doing so. The big downside to it is that it also prevents you from modifying the Quick Access. You won't be able to either pin or unpin any folders to it. Personally I have a pretty static list of shortcuts that I want there so it's not a big deal. You can of course uncheck the "deny" checkbox in step 5 at any time if you wish to modify your Quick Access again.

Source: https://www.tenforums.com/software-apps/134153-how-stop-program-adding-quick-access-shortcut-3.html

Hiding the Virtual Drive:

  1. Right click the Google Drive icon in the system tray and click the cogwheel. In the preferences window click the cogwheel again. From the pull-down menu, change the Google Drive drive letter to something unlikely to ever be used, I chose "L";

  2. Open the Registry Editor (Win+R, type "regedit" and press enter);

  3. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer;

  4. If you don't have a NoDrives DWORD in the window on the right, right click a blank area, click "new" and click "DWORD (32-bit) Value". Name it "NoDrives" and hit enter;

  5. Double-click NoDrives to modify it, set it to Decimal, and fill in the value data. The value differs depending on what drive letter you assigned to Google Drive. I assigned it to L so my value is 2048. Check the source link below for a table showing what value belongs to which drive letter;

  6. Restart the Explorer task, or sign out and back into Windows, for the changes to take affect.

Step 1 prevents Google Drive from possibly getting assigned a new letter if you occasionally have removable media mounted (e.g. an USB stick). This is important because with the registry change above you're hiding a drive based on the drive letter, regardless of which drive it actually is. Note that the drive is only hidden above-water, you can still browse to it by other means (e.g. by typing L:\ in the File Explorer's address bar).

Source: https://www.tenforums.com/tutorials/79149-hide-specific-drives-windows.html

1

Here is how I solved it, by generating a static Quick Access('QA') config & having it re-applied daily

Quick Access Loc:

%appdata%\microsoft\windows\Recent\AutomaticDestinations\f01b4d95cf55d32a.automaticDestinations-ms

Procedure:

  1. Setup your File Explorer Sidebar as you want

        *e.g. mine: QA showing 9 dirs with Dropbox, Google Drive\ & Network\ listed below it

  1. Copy that file! (f01b4d95cf55d32a.automaticDestinations-ms)

        *e.g. I copy to C:\Tasks\Sidebar\

  1. Create a batch file that copies this file, to the target dest (Ref)

  4. Setup a scheduled task, to perform this batch file (I run when I log on) (Ref)

Done. File Explorer will have to be closed and re-opened to update

1
  • gosh that took effort!
    – J-Dizzle
    Dec 18, 2021 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.