2

None of my windows DNS clients able to register A record in the DNS server. Ubuntu and Raspbian clients are able to register A record.

DC :

  • DNS server - Win Server 2019 / Microsoft Windows DNS server zone name "zone1" / private IP 10.1.0.5 / hostname "vm" / FQDN "vm.zone1"
  • Azure Openvpn virtual network gateway provides DHCP details to clients with the DNS server as 10.1.0.5 and 208.67.222.222
  • DHCP server does not register the DHCP clients in DNS server hence DNS/DHCP clients will have to manually register in DNS

Remote sites:

  • All clients are here
  • Ubuntu, Raspbian, Windows 10 and Windows Server 2019 clients after connecting to openvpn can ping and resolve names successfully from 10.1.0.5
  • Ubuntu and Raspbian can even auto register its own address and hostname in DNS server -Windows 10 and Windows server 2019 (hostname "vm3" / primary dns suffix "zone1) have the checkbox "Register this connections addresses in the DNS" as checked for the vpn interface. But still it is not able to register its own address in the DNS server (10.1.0.5). Event id 8016 on all windows client says:

The system failed to register host (A or AAAA) resource records (RRs) for network adapter with settings:

   Adapter Name : {806576C3-06F9-466B-A11E-CC73E5071980}
   Host Name : vm3
   Primary Domain Suffix : zone1
   DNS server list :
        10.1.0.5, 168.63.129.16
   Sent update to server : <?>
   IP Address(es) :
     172.16.201.3

The reason the system could not register these RRs was because the DNS server failed the update request. The most likely cause of this is that the authoritative DNS server required to process this update request has a lock in place on the zone, probably because a zone transfer is in progress.

You can manually retry DNS registration of the network adapter and its settings by typing 'ipconfig /registerdns' at the command prompt. If problems still persist, contact your DNS server or network systems administrator.


In the above event all details are correct except "Sent update to server : <?>" why is this "?" it should have been "10.1.0.5". Unless it sends the update to the right IP address the registration will obviously fail.

FYI :

  • AD is not implemented and all antivirus, firewall, network security groups, ACL etc are disabled.

Update 1:

  • Besides ubuntu and Raspbian, even the DNS server itself is able to auto register its ip and hostname in the dns records.

Update 2:

  • Tried the registry and group policies in windows clients with default settings and also modifications in : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  • ipconfig /registerdns also gives the same event error

4
  • Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer.
    – Community Bot
    Sep 11, 2021 at 11:59
  • 1
    Updates are always sent to the nameserver listed in the domain's SOA record. Does a SOA query for your domain (nslookup -q=soa zone1.) show the correct FQDN of the server that is supposed to receive the updates? And if so, does that FQDN resolve to the correct server? (I suspect it does not, because the system's DNS server 208.67.222.222 isn't going to know anything about your internal domains.) Sep 11, 2021 at 12:49
  • @user1686 your suggestion worked. Thanks.
    – Ankit Modi
    Sep 11, 2021 at 13:45
  • 2
    I don't know what you mean by "worked". If you've figured out the problem, please post an answer describing what the solution ended up being – I can't post one because I don't know which of the several different things that I was asking about was the relevant one. Sep 11, 2021 at 17:15

1 Answer 1

1

The FQDN of the name server mentioned in the SOA was not resolving earlier but reachable via IP. Fixed it now. Thanks @user1686

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .