0

I tried connecting my laptop with a Microsoft wireless display adapter, the connection only works if I disable my McAfee firewall. I don't have a lot of experience/know how about firewalls, but I tried implementing the rule detailed in this article https://success.trendmicro.com/solution/1119259-firewall-setting-configuration-for-intel-widi-miracast-in-officescan as well as this article https://kc.mcafee.com/corporate/index?page=content&id=KB85497&locale=en_US

but neither of them worked.

8
  • Have you disabled the Windows firewall, meaning do you have two firewalls? Is the wifi network marked perhaps as public?
    – harrymc
    Sep 14, 2021 at 12:43
  • @harrymc the windows firewall is not active, and the wifi is not marked as public
    – AalHai
    Sep 15, 2021 at 7:28
  • Try to find in the McAfee firewall a log of refused connections. I just note that the Windows Defender Firewall is just as good and less problematic.
    – harrymc
    Sep 15, 2021 at 8:19
  • @harrymc the "FirewallEventMonitor.txt" file is porbably what you're getting at right ?
    – AalHai
    Sep 15, 2021 at 8:58
  • I'm not a McAfee user (any more), so can only suggest directions.
    – harrymc
    Sep 15, 2021 at 9:03

1 Answer 1

0

In order to make the connection work without disabling mcafee, you need to first figure out the ip adress of your display adapter.

You can find this by trying to connect to it with the firewall enabled, and checking the "FirewallEventMonitor.txt" file, it shows up as a blocked connection with the WUDFHost.exe application. Next you need to go into advanced settings for your firewall and manually mark this ip adress as trustworthy.

2
  • I edited your answer to make it more easily readable. The edit will be viewable once a senior community member approves it. I think you have to wait for a couple of days, but when you can please accept your answer so that others who seek help can see that this question contains a solution. As a side note - your FW is company-mandated. If it's also company-managed, don't be surprised if you have to do this again at some point. I'd probably have a chat with the company IT guys about this. Sep 16, 2021 at 8:41
  • @Peregrino69 i will, i aready set up a meeting with the admin for later today
    – AalHai
    Sep 16, 2021 at 8:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .