0

This has been going on for about a year now but I am now attempting to do something about it.

On two separate systems, one Intel I7 and one AMD Ryzen 5, with plenty of RAM, I have the same thing happen. After a few times booting, the Nvidia Driver seems to stop working. I have tried a number of Nvidia Drivers, like the x86 64-470 or other versions like the 45* or 43* series, but they all do this. In addition, the two systems have different graphics cards, one is a GTX1060 and the other is an RTX2060.

It seems that the only point of similarity is the Ubuntu 18.04 LTS. I have never done an "upgrade" but have worked with the same software for over a year.

When the driver stops working, I check to see if I have already blacklisted Nouveau, which I have. I change to "runlevel 3" which is "sudo systemctl set-default multi-user.target" and then I run the driver (it complains otherwise). After that, and I get no really bad messages from the driver install, I go back to runlevel 5 "sudo systemctl set-default graphical.target".

That seems to work. Until it does not. I think that I never last more than 3 or 4 reboots before I have to redo the process.

Does anyone have any idea of how to fix this?

Thank You

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.