(System is Windows 7 x64)

I wanted to restrict access of other people in a certain drive of my computer (Harddisk 1 is partitioned to C & D; I want to restrict Drive D). What I did was go to the Security Tab (under Drive Properties) and remove the All Users entry. My account is an administrator account. I left only Systems and Administrator on the list. However, when I tried to access drive D, I got an Access Denied error, and Security Tab is already missing.

I tried to edit Local Group Policy; it does not work. Take Ownership is not available for the Drive as well, but I see it enabled if I select files / folders.

Please help. Thanks.

Also, I am wondering why, as an Administrator, have my access to that drive denied.


You do not always have an access to the files, even you are an administrator. In Windows, there are permissions, but also ownership. For example, on Windows Vista and later, if you try to remove a system file as an administrator, you will not be able to do it, since you are not an owner of this file, and the owner (one of the systems accounts, don't remember which one) did not grant you a permission to modify or remove the file.

Now, gladly as an administrator, you can change the owner of a file. Go to:

File Properties → Security → Advanced → Owner → Edit.

Select your name in "Change owner to" list and click Ok on every opened window (confirming all those annoying message boxes which will appear). Now you can grant permissions you want to yourself and access, remove or modify the file.

What do you mean when you say "and Security Tab is already missing"? Do you have Security tab for other drives? I'm pretty sure this tab is here even when a user does not have an access to the file, directory or a whole disk, at least for an administrator.

Probably it is something to do with your options. Maybe "Simple file sharing", a crappy thing like this which made everything really difficult when enabled under Windows XP?

  • Hi MainMa, Yes, Security Tab is there for Drive C. I'm pretty sure I do not have a malware that caused this, as this tab was there prior to my action (described in my post). Before, I have something like the following in my Security Tab: System Administrator All Users I deleted All Users, then I clicked ok. I did this for Drive D, not for the folders inside Drive D. Then, when I clicked on Drive D, I got access denied. When I checked on the drive properties, Security Tab is gone.
    – darkstar13
    Jul 26 '10 at 2:22
  • I read something that I should change Local Group policy settings to Disable 'No Security Tab', and I did, but the tab is still missing after several boots. I tried booting into Safe Mode, and I can't seem to, no matter how I press F8 right after BIOS post.
    – darkstar13
    Jul 26 '10 at 2:22
  • As for File sharing, I did not change anything under Sharing Tab.
    – darkstar13
    Jul 26 '10 at 2:23
  • Create a new folder (on another drive). Create a file inside. Remove every permission on this folder (removing permissions inheritance when need). What happens? Can you see the Security tab? Jul 26 '10 at 3:41
  • Also, have you tried to disable UAC? Don't really see how it could help, but since it is another crappy thing which makes things worse and since it is related to the security, maybe there is a link to make. Jul 26 '10 at 3:44

I have the same problem with one of my uses who made this blunder. to recreate the problem follow following steps on the Drive not a folder open security tab Remove all users and privileges click yes to all warning messages close out everything and open the properties of the Drive Wallah security tab gone and all access to the drive is denied no way to get the advance options or get somewhere where i can add the privileges. As i said earlier it only works for drive and not the folder.

BTW working on Windows 7 64bit NTFS HD, i have tried everything access to the drive is denied and i can't get to the security tab to add privileges

I finally figured out the solution it was as simple as going into safe mode that's it. Once logged into safe mode you have access to the security tab on the drive which was not there in the normal mode. Once i had access to the security tab i changed the ownership and other privileges and gained access to the drive.

  • but this one made my day! thank you for saving my data! :)
    – Cornelius
    Jan 26 '11 at 8:25

Boot the computer to safe mode and you will see the Security tab. From there, allow the users you have denied and save. Then go back to normal mode and your drive is back to normal. That worked for me.


In windows 7, being a member of the Administrators group does not grant you administrator privileges by default. Rather, it grants you the ability to request those privileges when needed. See if you can open an explorer window using the "Run as Administrator" option on the right click menu.


For reasons I do not understand changing the owners of the file do not work.

Also allowing administrators full access also do not work.

I have to explicitly grant my self, an administrator, access to the whole drive. Then it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.