13

I periodically experience a disconnection with my laptop. The connection period lasts about 3-6 minutes. I know for certain that the WiFi works fine.

Using the command sudo journalctl --since="-2 minutes" I find that a recurring line is:

(...) Using degraded feature set UDP instead of TCP for DNS server 10.64.10.16.

What should I do ? I cannot work since the connection conditions are definitely unstable. I have recently noticed that it is a quite common problem.

I have ubuntu whose version is 21.04, and my laptop is an Acer Aspire 3 A315-56 with a WiFi connection.

8
  • 2
    Your DNS resolver (maybe systemd-resolved?) might be normally using DNSSEC/EDNS0, and using a TCP connection to DNS server because of this. When you have a connection problem, it notices TCP connection is failing and reverts to UDP and basic DNS protocol. But if you still experience a disconnection, that probably means the reversion to UDP is not helping, perhaps because the actual connection to the destination website (or whatever) still uses TCP and still fails. What is your basis for the conclusion that WiFi works fine? (I'm asking to exactly identify the known-good element(s).)
    – telcoM
    Sep 16, 2021 at 18:15
  • 2
    Things to try: (1) Use another DNS server than that of your ISP (example), (2) Disable IPv6 in your local network, (3) Set DNSSEC=no in /etc/systemd/resolved.conf.
    – harrymc
    Sep 16, 2021 at 19:46
  • @telcoM I can observe a download plot from another machine. This download is continuous with a constant download speed of 80 kb/s (which is the expected speed). In this way I can observe hypothetical WiFi crashes if any.
    – Siderius
    Sep 17, 2021 at 15:40
  • I have noticed that resolvconf was missing. After that, as @harrymc suggested I have set DNSSEC=off (commenting it out) through the command: sudo nano /etc/systemd/resolved.conf After that the cmd sudo systemctl restart systemd-resolved.service
    – Siderius
    Sep 17, 2021 at 16:29
  • Did this change anything? (Or you don't know yet)
    – harrymc
    Sep 17, 2021 at 16:36

5 Answers 5

8

I had advised doing the following:

  1. Set DNSSEC=no in /etc/systemd/resolved.conf
  2. Use another DNS server than that of the ISP (such as Google Public DNS)
  3. Disable IPv6 in the local network (is perhaps not helpful).

The poster has reported doing this:

I have set DNSSEC=no (commenting it out) through the command:

sudo nano /etc/systemd/resolved.conf

After that the cmd:

sudo systemctl restart systemd-resolved.service

with a reboot.

For changing the DNS servers, the poster has followed the article
How to Set DNS Nameservers on Ubuntu 18.04.

For the moment, the poster's system seems stable.

0
1

1.remove the link file /etc/resolv.conf
2.create a real file /etc/resolv.conf, add two line in it

nameserver 8.8.8.8
search . 

3.add DNSSEC=no to /etc/systemd/resolved.conf
4.restart systemd-resolved.service or reboot \

it works. the link

1
  • 1
    On Ubuntu 22.04, upgraded packages, probably a new version of netplan inside. syslog massively flooded by Using degraded feature set TCP instead of UDP for DNS server x.x.x.x. These 2 changes solved the problem. Thanks a lot !! Dec 27, 2023 at 11:24
0

Try this.

sudo dhclient -r wlo1 && sudo dhclient wlo1

replace wlo1 with your network name.

In my case it was because the office firewall was blocking my IP address.

-2

I solved it by setting up DNSSEC on bind9 nameserver as per this rather old Digial Ocean tuorial (note it will need a few tweaks - mainly use an existing zone file instead of the 1 liner they recommend before the $INCLUDE statetements added by the do loop) and this article

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Apr 30, 2023 at 14:47
-2

I solved it by setting up DNSSEC on bind9 nameserver as per this rather old Digial Ocean tuorial (Note you need to preset the example.com.zone with your current forward zone file before the $INCLUDE statetements added by the do loop step in the article). This article covers the steps needed to create a signed reverse zone should your nameserver support PTR record lookup.

1
  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – Destroy666
    Apr 30, 2023 at 20:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .