0

I try to delete a selected area from a png picture in GIMP 2.10.24 (using Ubuntu Linux). (I've done that countless times, and it always worked! I don't know what makes the current png different...)

When I select an area (in my case with the "Rectangle Select Tool") and hit delete, nothing happens.

I've searched for that problem, and in several posts and websites only two possible reasons are mentioned:

  • Check that you do have an Alpha channel, add it if not. (Layer > Transparency --> Then you'll see either add or remove alpha channel.)
  • Check that the alpha channel is not locked. (On the right where all layers are listed, above it you see "Locked:" with three symbols behind. Make sure they are not 'marked'. Marking is not clearly visible, it's just the background color that changes slightly.)

Anyway, none of these apply to me, so all should be right -- thus causing my frustration.^^ Therefore, can anybody please tell me:

  1. How to solve the problem so that selection + delete does work as always?
  2. What is causing that problem? Important info: After I posted this question [i.e., this is an edit done afterwards], I was again able to delete marked parts as I could do in the past thus proving that it's actually not a property of the png that causes this, but it's apparently just non-deterministic behavior of Gimp (as also indicated by the title of the stackoverflow post linked above). Still, 'something' should cause this. Any idea, what?

Here a partial workaround, inferred from a similar question, phrased as Gimp allows only sometimes to select and delete. The work-around solution is as follows:

  • Just select the area you want to delete as usual. (That's the default first step anyway -- normally you would then just hit the delete button!)
  • Instead of hitting delete, now hit Select > Float. This causes the creation of a new layer consisting of only the selection.
  • Now hit the 'eye' of that layer causing it to become invisible (i.e., it's practically excluded from the current view thus 'deleting' it.)
  • After that, just click outside the selection (or outside the 'canvas' I think; I mean the large surrounding gray area). This causes the new layer to disappear. Thus, the final result is now the same as if hitting delete would have worked right away. It's just much more complicated...
4
  • For the sake of completeness: The following question (graphicdesign.stackexchange.com/questions/140528/…) might face the same problem, but again only only of those answers that I already provided above is given there -- so it doesn't help.
    – Prof.Chaos
    Sep 18, 2021 at 10:04
  • 1
    Please don't add comments, update your question. That way nobody has to browse through comments to find relevant info - or additional questions. Sep 18, 2021 at 12:20
  • Hmkay, I deleted the last one since/and I updated my question accordingly. If you delete your comment, I will delete this one as well. :) (Since it's actually not relevant for others anymore.) However, I still feel like my first comment is better suited as a comment than as part of the question (as its only an addendum only indirectly related to the question).
    – Prof.Chaos
    Sep 18, 2021 at 12:43
  • I'd add that to the question, but doesn't make that much diff. I just wanted to point this out as extended comment threads are kinda bi* to follow :-) Sep 18, 2021 at 12:49

1 Answer 1

1

When I was unable to delete a selection, it was because I had previously copied another selection resulting in the creation of a floating layer that I was operating on instead of the layer I had originally selected.

I just had to find the Layers dialog, notice the layer labelled "Floating Selection (Pasted Layer)", and click the little Anchor-shaped button on the toolbar at the bottom of the Layers dialog. Then I was able to delete my selection from the layer I originally selected with the Delete key.

Image of Layers dialog showing floating selection layer and anchor button

(You sound like a more sophisticated user, so this is probably not your issue, but I mention it for any novices like me who are searching in the future.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.