0

Trying to update Windows in my newly reinstalled Lenovo Ideapad 710s. Got error:

• Feature update to Windows 10, version 20H2 - Error 0x80004005

I was trying fix problem with Troubleshoot. According to my understanding it just wipes last updates and allows to download once again. But next time I have the same problem. Disc contains 80GB free space.

How to fix this problem?

I tried to reinstall Windows, but got the same issue.

I'm running Windows 10 Home, version 1607 OS Build 14393.2214

2
  • Please edityour question and provide the output from SetupDiag which will contain the necessary information required to answer your question.
    – Ramhound
    Sep 20 '21 at 12:07
  • I would also instead of using Windows Update use the Windows Upgrade Assistant. You might get different results. It also would be nice to know what version your currently running. As always edit your question instead of submitting a comment
    – Ramhound
    Sep 20 '21 at 12:13
0

First make sure you truly have 80 GB of free space. Some may have been used up on repeated attempts.

Try the first post in this Microsoft thread.

Update Failure

Step 2:

a. Press Windows Key + X. b. Click on ‘Command Prompt (Admin)

Note: Click ‘Yes’ if it prompts for UAC(User Account Control). c. Type following commands into the command prompt one after the other

net stop wuauserv

net stop bits

net stop cryptsvc

Keep Command Prompt window opened.

Rename Windows Update folders

At the command prompt, type the following commands, and then press Enter after each command:

ren %systemroot%\System32\Catroot2 Catroot2.old ren %systemroot%\SoftwareDistribution SoftwareDistribution.old

Then type the following, commands and then press ENTER after each command:

net start wuauserv

net start bits

net start cryptsvc

Close the Command Prompt window and check if you can install the updates.

If this does not work, you may need to back up and reinstall Windows (as easy as some repairs).

4
  • I was trying to delete all from C:\Windows\SoftwareDistribution , but I cant delete DataStore folder. Restart hot helps
    – vico
    Sep 20 '21 at 13:38
  • You may need to reinstall Windows as I noted to fix things. If there are significant issues, back up and reinstall is usually easiest .
    – John
    Sep 20 '21 at 14:28
  • I tried to reinstall Windows, but got the same issue
    – vico
    Sep 21 '21 at 5:35
  • It may be that your computer is at the end of the road and won't run newer Windows 10. There may be a hardware issue - run memtest86.exe to check memory. Run the manufacturers hardware diagnostic app.
    – John
    Sep 21 '21 at 10:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.