Having this problem with Visual Studio 2010 Ultimate where it hangs when trying to open any file.

This is a very specific setup, so I don't even know where to start searching for a solution. I'll try and specify as much information as possible:

  • Visual Studio 2010 Ultimate
  • Windows XP Professional SP3
  • Using some kind of VPN connection to access the company's servers
  • Connected to Team Foundation Server for source control

Syncing the solution works just fine. Even checking out a file for edit seems to work. But when trying to open a file (even one previously checked out for editing), Visual Studio just hangs there. Trying to do stuff in it makes the following message appear as a popup notification in the Windows taskbar:

Microsoft Visual Studio is waiting for an internal operation to complete. If you regularly encounter this delay during normal usage, please report this problem to Microsoft.

Any idea of what the problem might be? Thanks in advance.

UPDATE After much trial an error, it seems to be possible opening some files by doing "Open with..." from Windows explorer, BUT ONLY when a solution is not open in VS already.

  • Do you have any VS add-ins installed? – Vasyl Boroviak Jul 26 '10 at 10:25
  • Is the file you are trying to access local, or is it on your company's server? If it is on the server, do the local files generate the same error? – ubiquibacon Jul 26 '10 at 10:36
  • No VS add-ins installed. The hang happens both in files on the server and on local ones (created a test project locally and it was still hanging). – Farinha Jul 26 '10 at 19:30

Fixed the problem by installing Visual Studio 2010 Professional (instead of Ultimate). Go figure...


Try stripping out the source control bindings and seeing if that speeds it up. if so your problem is VS trying to talk to TFS.

Also see http://msmvps.com/blogs/p3net/pages/tfs-2010-in-offline-mode.aspx for work arounds in the event you want want to have a quick back and forth option.

Also the SO question and this one

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.