0

I have a hard drive that I need to copy from one drive to the other in a Windows 10 machine. The source drive has a single folder, read only. When I try to run robocopy, it does not not see the folder on the source drive. I can see the folder in Windows Explorer, and run files from the source drive, but I cannot navigate to that folder in command line. I do not want to mess with the attributes of the source if I can avoid it, as the source drive was recovered from a failing hard drive. Both drives are internal and connected via SATA.

Any idea why I can't see it in command line?

Command line screenshot

Windows Explorer screenshot

0

3 Answers 3

1

You have changed the folder on D:, but you have stayed on C: as your current disk.

Use the CD command with the /D parameter to also change the disk:

cd /d D:\620547

Or do the equivalent two commands:

cd D:\620547
D:
3
  • This answers the CD issue, but robocopy still fails and can't seem to see the drive. I thought maybe the two were related, running robocopy as below: robocopy D:\620547 X:\ /E /COPY:DAT /DCOPY:DAT /R:0 /W:0 /TEE LOG:log.txt Result: ERROR 123 (0x0000007B) Scanning Source Directory D:\620547\ The filename, directory name, or volume label syntax is incorrect. Tried adding \NOCOPY per another thread on here, but that did not fix it either. Tried running explorer as admin, and visiting the drive in explorer, as suggested in another thread, but no change either. Sep 21, 2021 at 19:41
  • 1
    Some of your parameters seem wrong, for example `x:`. Check against the documentation.
    – harrymc
    Sep 21, 2021 at 19:46
  • X:\ is the drive letter of the destination. But you caught it, I was missing a / before LOG. Thank you Sep 21, 2021 at 20:47
2

Any idea why I can't see it in command line?

Your cmd shell is still on the c: drive.

You need to use cd /d d:\620547 to change the drive and the folder:

/D : change the current DRIVE in addition to changing folder.

Source: CD Change Directory - Windows CMD - SS64.com

-1

If you say you can't navigate to the folder in the command line...have you tried:

attrib -h -s -r 

It's possible that the folder has a hidden attribute assigned to it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .