0

After Google forced the new Google Drive for Desktop to Backup and Sync users, it deleted over half my files. And I can not locate where are the offline files are saving either. Now I uninstall the app.

Does anyone have experience with how to install the new Google Drive and keep files offline while syncing enable?

Note: I do not want to save files on C: dive on windows 10. How can I change offline files to a different directory?

1 Answer 1

2

Please follow the below steps to move offline file cache in Windows 10:

  • Create a folder for your offline file cache. Something like D:\Offline.
  • From an elevated command prompt type the following: Takeown /r /f C:\Windows\CSC.
  • Open the Sync Center and go to Manage Offline Files.
  • Click Disable Offline Files and restart the machine.
  • From an elevated command prompt issue the following commands:

rd /s C:\Windows\CSC mklink /J C:\Windows\CSC "D:\Offline" (or whatever your folder name is, but be sure to use the quotes if you have space(s) in the name).

  • Reopen the Manage Offline Files window and Enable Offline Files.

  • Restart the machine. All files/folders that are made available offline should now be redirected to whichever folder you specified.

I hope this information is helpful. Please post in case you have any further issues, we will be glad to help you further.

7
  • Totally unix style. Note the way she uses a junction to trick the program rather than messing with settings (which are probably not even an option). I use this trick all the time with ANY APP that I don't like where it put stuff. NICE JOB Amelia! Sep 24, 2021 at 14:42
  • thx Señor CMasMas Sep 25, 2021 at 9:46
  • @AmeliaSanderas Thank you very much for your kind reply. I have tried to follow your steps. However I get an error. I don't have programming skills unfortunately. C:\WINDOWS\system32>Takeown /r /f C:\Windows\CSC ERROR: The system cannot find the file specified.
    – Dendrobium
    Sep 26, 2021 at 6:57
  • 1
    Try (from an elevated command prompt) changing the command to Takeown /r /f %windir%\CSC Your search for CSC found a program that is part of .net, not the folder miss Amelia was referring to. Trust me, the folder is there. Try again. Sep 26, 2021 at 17:33
  • 1
    There is something going on because those commands should have worked. We could beat a dead horse figuring it out.. but instead, lets try using the explorer to take ownership of stuff. This might be easier for you if you are more of a graphical person. Open the explorer. Find your windows directory, then CSC. Right click and follow the instructions provided in the link. Sep 29, 2021 at 15:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .