7

When I'm using Google Chrome and many other Chromium-based browsers including Vivaldi and even the new Edge, certain websites will show a pop up with "sign in as" if I have password stored for that website. Some of such websites include Imgur, Twitter, Instagram.

example on edge

example on vivaldi

Since the pop up will always appear on page load, it's getting very annoying, especially when you just want to check something fast on the website and not intending to log in, when the content is accessible without login in the first place.

Especially annoying with Imgur, as many people use Imgur to host or share their images, and Imgur always show that pop up every single time I open link to view the image details, and that meant I had to click "Cancel" on that "sign in as" pop up every single time as well.

I have disabled the option that says "auto login" in the password section, because I do not want to log in, regardless automatically or manually, but it still prompt with the "sign in as" pop up.

This question is different from How do I disable the Chrome Sign-In popup? since the pop up on that question is part of websites HTTP auth that do require log in and it's asking credential for that auth, while my question is for websites where log in is not required for the access.

This question is also different from How to disable Google One Tap sign-up prompts? as that's just part of Google Account sign-in prompt which can be disabled from Google account setting and not related to browser. In fact that prompt is less intrusive since it's just a small box appearing on corner of website itself that can be ignored, while the browser's "Sign in as" pop up is literally blocking the whole browser, I need to click "Cancel" every single time it pops up, even when I'm on different tab. For example, loading website with that function on new tab in the background while I'm still on original tab reading stuff there, it will still suddenly prompt me right there and disrupt me reading, it's way more intrusive.

On other hand, this question is similar to Disable chrome "sign in as" popup but the accepted answer does not work anymore, as the website will just be blank if I use the script given in the answer. I initially wanted to comment on the accepted answer on that question asking for update, but it needs me to have 50 reputation to be able to comment, which I don't have, so I'm asking separately.

I need the saved credentials to still be available in the browser's own password manager, so removing password from there just so the website would not pop up 'sign in as' is not an option for me. I want to block the pop up itself and still have the actual password in manager. I will log in when I wanted to, don't pop up such prompt every single time I visit the website without logging in.

0

2 Answers 2

2

Disclaimer: Bear in mind I am using Vivaldi 6.5, which is a fork of Chromium, so this should still work as expected, but it might not.

I was dealing with the same issue; I believe I've found a way around this.

Assuming the pop-ups you are seeing show in the top right of your browser window and are similar to the ones below:

"sign in to .com with google.com"

I found documentation here, but to summarize:

  • Go to Chrome-native settings, which should be located at chrome://settings
    • If on non-native Chrome, you may attempt to use your browser's native settings (i.e. vivaldi:settings--as far as I can tell, this does not work and you must must go to Chrome-native settings
  • Privacy and security > Site settings > scroll down to Additional content settings > Third-party sign-in > Block sign-in prompts from identity services
    • Alternatively, copy and paste chrome://settings/content/federatedIdentityApi

Should look like this after changing the setting: third-party sign-in set to block such prompts

Et voilà! Do a quick refresh of whatever problem page you're on to do a before and after comparison, just to ensure it works. I've heard medium.com is an offender of this, but YMMV.

(Sidenote: I was also messing with chrome://flags/#third-party-profile-management and it is currently disabled on my browser, but that seems to have no effect on the pop-ups from what I can tell.)

4
  • it seem like that doesn't work -- I tried both chrome://settings/content/federatedIdentityApi and chrome://flags/#third-party-profile-management separately, and both at same time, including closing and launching my browser after changing each of them, and such website would still trigger it (including on the example website you gave, which is medium.com)
    – Yaya MNH48
    Mar 16 at 14:49
  • That's unfortunate--are these pop-ups occurring in the middle-top of the screen or some other location? (Mine were appearing in the top-right, but seeing as the solution doesn't work, clearly yours must be different.)
    – gregCubed
    Mar 18 at 21:00
  • @YayaMNH48 You might want to check chrome://password-manager/settings and see if checking the "sign-in automatically" slider is disabled, since that mentions it will "[ask] for confirmation every time". That might introduce a new issue where you get signed in every time you visit a site automatically, though.
    – gregCubed
    Mar 18 at 21:10
  • I can't disable that setting because I don't want to get sign in automatically, I want to have control over when would I sign in to certain website
    – Yaya MNH48
    Apr 7 at 23:51
0

On Vivaldi, go to Preferences... / Privacy and Security / Website Permissions / Global Permissions / Third-Party Sign-in and choose "Block"

1
  • this does not work, I already have that setting set to "Block" to begin with
    – Yaya MNH48
    Apr 7 at 23:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .