1

I am logged in in Chrome with my Google account.

However, Chrome does not autofill passwords from that account.

Settings->Autofill->Passwords gives this: enter image description here

No saved passwords, but I can login to my Google Account with the link. When I click the link, I get to passwords.google.com and see all (masked) passwords from my account. I don't need to login more than the first time in order to see them.

A "Clear bookmarks, history, passwords" upon turning off Sync does work the next time I login... until it breaks again. I don't want to need to take this step all the time.

How do I make Chrome get the login information and autofill it in login forms?


Edit 5 months later (Feb 2022): this happens again. My passwords are in my account, I am logged in in the browser, Chrome suggests usernames, but does not fill in passwords.

Solved with "Turn off sync", and clear passwords/cookies/cache as suggested in the dialog tick box. I don't think this is an expected feature :)

17
  • Passwords seem to be working fine here. Consider uninstalling Chrome and your Chrome Profile. Restart. Install the newest version of Chrome and set it up again.
    – John
    Sep 28, 2021 at 12:52
  • If you enter manually a password, does Chrome offer to keep it, and is it then truly kept? (Add to your comment @harrymc for me to be notified.)
    – harrymc
    Sep 28, 2021 at 12:53
  • @John Fresh install from today.
    – Gauthier
    Sep 28, 2021 at 14:06
  • @harrymc Yes, it offers to keep it. But it does not autofill it next time.
    – Gauthier
    Sep 28, 2021 at 14:07
  • Try: (1) Check for conflict with some browser extension, by using Incognito mode. (2) Clear Browsing Data, (3) Create a new Chrome user profile and check if it works for it.
    – harrymc
    Sep 28, 2021 at 14:32

4 Answers 4

0

I was having the exact problem. It seemed to do with the fact that I have more than one Google account and for whatever reason, Chrome kept defaulting to the wrong one (little used, no saved passwords). Though it was asking me if I wanted to save passwords, those were going to my primary Google account and not being saved into this other profile. Go figure! I signed out of all Google accounts, then signed back into both Google and Chrome with my primary account and it's all working again. Hope this helps.

3
  • Nice idea, but Chrome manages to get the usernames, it's just the passwords. When I go to settings, autofill, passwords, and to the link in the screenshot of my question, it asks for password every time. I think this is an authentication issue.
    – Gauthier
    Oct 5, 2021 at 15:05
  • Did remove the alternate profile (although I'm positive it was never selected), logged out (turn off sync), closed. Then re-opened, turned sync on. I think I'm now logged in on the sites, seems good so far.
    – Gauthier
    Oct 5, 2021 at 15:07
  • Nope. One account, Sync off, restart, sync on -> no password fill. Settings -> Autofill -> Passwords -> Google account shows me the data is there, but trying to access the passwords themselves always prompt for a master password (my Google account's).
    – Gauthier
    Oct 20, 2021 at 12:34
0

I'm guessing it has to do with Windows-Encryption not working. Guessing Chrome sync tries to download/cache the passwords on the local PC, BUT it needs to do that securely (via encryption) so viruses can't easily access plaintext passwords. Clearly google HAS your passwords since you see it on that passwords.google.com site but the Chrome application doesn't.

Some questions:

  1. Can you try this google account on another PC? I imagine it'll work & that'll confirm its not the google account

  2. If you sign into Chrome with a different google account & enable sync do those passwords show up in Chrome (without accessing passwords.google.com) & autofill?

  3. In admin command prompt do the following commands, wait for each to finish before progressing to next. Then try to replicate issue:

    • sfc /scannow (link)
    • dism /online /cleanup-image /restorehealth
    • chkdsk /f (link)
  4. Have you reviewed Event Viewer? Focus on Application & System. Might want to look in Applications and Services, Microsoft, some item here

  5. Process of elimination ideas that might help narrow down the issue:

    A. If you don't sign into a google account can you save a password, reboot PC, then it'll auto-fill? If that works it negates my Win encryption not working theory

    B. Try sync/chrome-login with user-chrome-app. When you install Chrome it'll ask for admin credentials, click cancel & it'll install Chrome to appdata instead of Program Files. Logging into PC as limited/non-admin user will also accomplish this. This will confirm if your chrome installation is the problem

    C. As others have pointed out you really should uninstall chrome, reboot PC, then reinstall it. I hope you've tried that already

    D. Try an older version of Chrome

    E. I assume you've tried the various Google articles: Get your bookmarks, passwords & more on all your devices; Fix issues with sync in Chrome; Fix issues with saved payment info & passwords

2
  • Thanks for the effort, I am on a fresh install of Ubuntu. It also happened at home, on an old install of Ubuntu.
    – Gauthier
    Oct 25, 2021 at 11:08
  • What works is Turn sync off, with Clear local data in the same dialog. Then Turn sync on again after a restart. I need to answer all the questions that are usually stored in cookies again, but it is less painful than doing the round-trip to my Google Account every time.
    – Gauthier
    Oct 25, 2021 at 11:10
0

You're today completely dependent on one browser, Chrome, and on one device, your computer.

To liberate yourself from this dependency, I would suggest using a third-party product that is cross-browser and cross-platform. You could then have your logins on your computer, on your phone, on Chrome, on Firefox etc. etc.

Here are several possibilities:

3
  • +1 for KeePass, they are available in many platforms and it's free
    – Luciano
    Oct 27, 2021 at 9:34
  • I will consider this, but my passwords in Chrome are synchronized on my work computer, home computer, and phone. Not "on one device"
    – Gauthier
    Nov 17, 2021 at 16:26
  • @Gauthier: All these products are multi-platform and multi-device (except Lastpass requires the commercial version).
    – harrymc
    Nov 17, 2021 at 17:05
0

This happens every few months, and my current work-around is this:

  • turn off sync
  • in the confirmation dialog, tick the option to clear cache and cookies and passwords
  • chrome starts in some kind of standard vanilla mode
  • turn on sync again

You lose local data, but the passwords get filled in again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.