0

I build a new HGST Ultrastar He10 10TB drive into my machine. I have multible of these, and all show the same capacity (~1TB).

They were previously used in RAID setting where they showed correct sizes (10TB) but I planed to use just of of them as a HDD extension for my system.

Doing sudo lsblk I get:

sdd      8:48   0   1,1T  0 disk                                    │
└─sdd1   8:49   0   1,1T  0 part

so only 1.1TB of space.

Same happens when I do check it with GParted.

Any ideas why I dont get the full 10TB on all those drives?

Edit:

Output of sudo fdisk -l /dev/sdd

Disk /dev/sdd: 1,1 TiB, 1204738326528 bytes, 2353004544 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 497F147C-3BC9-4F24-B2F1-7C0C1D8C30B8

Device     Start        End    Sectors  Size Type
/dev/sdd1   2048 2353002495 2353000448  1,1T Linux filesystem

Gparted Screenshot:

GParted Screenshot

Gparted Screenshot (after deleting partition)

enter image description here

Motherboard and Controller

Ouput of dmesg | grep DMI:

[    0.000000] DMI: Micro-Star International Co., Ltd. MS-7B48/Z370-A PRO (MS-7B48), BIOS 2.90 04/02/2019

Output of lspci

00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Device 3e92
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th Gen Core Processor Gaussian Mixture Model
00:14.0 USB controller: Intel Corporation 200 Series/Z370 Chipset Family USB 3.0 xHCI Controller
00:14.2 Signal processing controller: Intel Corporation 200 Series PCH Thermal Subsystem
00:16.0 Communication controller: Intel Corporation 200 Series PCH CSME HECI #1
00:17.0 SATA controller: Intel Corporation 200 Series PCH SATA controller [AHCI mode]
00:1c.0 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port #1 (rev f0)
00:1c.3 PCI bridge: Intel Corporation 200 Series PCH PCI Express Root Port #4 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Z370 Chipset LPC/eSPI Controller
00:1f.2 Memory controller: Intel Corporation 200 Series/Z370 Chipset Family Power Management Controller
00:1f.3 Audio device: Intel Corporation 200 Series PCH HD Audio
00:1f.4 SMBus: Intel Corporation 200 Series/Z370 Chipset Family SMBus Controller
01:00.0 VGA compatible controller: NVIDIA Corporation GV104 [GeForce GTX 1180] (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 10f8 (rev a1)
01:00.2 USB controller: NVIDIA Corporation Device 1ad8 (rev a1)
01:00.3 Serial bus controller [0c80]: NVIDIA Corporation Device 1ad9 (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
19
  • Welcome to SU. Do you mean gparted doesn't show the complete disk? Can you maybe post a screenshot of gparted together with sudo fdisk -l /dev/sdd -output? Sep 29 at 14:00
  • Thanks for the fast response! Screenshot and output is updated now! Maybe as an addition: what i tried is making a new partition table and formatting it to ext4. Sep 29 at 14:11
  • What is the brand and model of the HDD? You say you're seeing this on several drives, did you buy them all at the same time, from the same place? Have you checked for firmware updates for the drives? When they were RAID did they report the correct size? Sep 29 at 14:13
  • Heh... music2myear was faster :-D Indeed the brand and the model of the HDDs would be helpful. Sep 29 at 14:18
  • @music2myear Brand and model is HGST Ultrastar He10 . I don't know when they where bought but they worked correctly on that RAID system. Sep 29 at 14:18
3

Sounds like whatever controller you’re using isn’t up to the task. With 512 byte LBAs and a 32-bit number of them, you can address at most ~2.2 TB.

As per the extended drive documentation, the real sector count is 19,532,873,728. Compared with what fdisk reports:

 32   28   24   20   16   12    8    4    0
  v    v    v    v    v    v    v    v    v
    1000 1100 0100 0000 0000 0000 0000 0000 = 2,353,004,544
100 1000 1100 0100 0000 0000 0000 0000 0000 = 19,532,873,728

Try with a better disk controller.

5
  • I think you might've cracked the code. 2353002495 + 2048 = 2353004543. Sep 29 at 14:55
  • They where previously used in a RAID setting and I just wanted to use it in my local machine. Is there still something like a disk controller for that? Sep 29 at 15:02
  • @some_name.py yes, everything needs a controller in order to communicate with the device. Even memory has a controller. In the past it's very common for disks to work perfectly inside the case but then doesn't have the full capacity recognized when plugged into an external USB case, for example this one or this one
    – phuclv
    Sep 29 at 15:09
  • @some_name.py - Your question makes no mention of that fact.
    – Ramhound
    Sep 29 at 15:55
  • @Ramhound Yes your right I should made that point clearer and a bit of it got lost in the edits. Sep 29 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.