0

I'm trying to open a remote application that needs WebGL, but some of the users manually disable it for other reasons. I tried to activate by command line, but it doesn't work, I tried several combinations, I know Chromium must be closed to accept the settings.

The command on the server looked like this:

chrome --enable-gpu -–use-gl=desktop --app="http://localhost:8000"

I read this documentation about Switches: Run Chromium with flags

In it I found a very detailed list: List of Chromium Command Line Switches

Even so Chromium or Google Chrome always starts disabled if the user has manually disabled it: enter image description here

What's really weird is that if hardware acceleration is enabled and I try to start with the command line to "enable" WebGL is also disabled.

This leads me to believe that I am not using switches correctly.

2
  • The URL to the detailed list does not work.
    – Ramhound
    Sep 30, 2021 at 19:33
  • I'm sorry. Now it's fixed
    – RpgBoss
    Sep 30, 2021 at 20:22

1 Answer 1

0

After some tests I managed to solve, the Switch was missing --in-process-gpu

Result:

start chrome --app="http://localhost:8000" --gpu --gpu-launcher --in-process-gpu --ignore-gpu-blacklist --ignore-gpu-blocklist

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.