32

The shell in macbook makes annoying beep/bell/boop sounds.

For the OEM terminal, this answer works on disabling this annoying sounds: https://stackoverflow.com/questions/19166539/i-want-to-disable-beep-sound-in-terminal-mac-osx

However, I could not figure out how to do this for iTerm2.

I have notifications for iTerm2 disabled in System Preferences -> Notifications -> iTerm but that doesn't seem to work.

2 Answers 2

54

To disable the bell sound in iTerm2, do this:

  • iTerm2 -> Preferences -> Profiles
  • Under Terminal tab, you will see Notifications header. Toggle the Silence bell option.

enter image description here

EDIT: Please note that intuitively you might think that you want the Silence bell to be checked, but if it's already checked then unchecking it will resolve your issue. So, basically toggling it seems to be the key.

8
  • 3
    Also make sure you disable the notification center "send bell alert" :) SO ANNOYING Nov 18, 2021 at 9:32
  • 20
    Checking the "Silence bell" option turns off sounds for me, not unchecking it.
    – Ryan
    Dec 2, 2021 at 15:52
  • 2
    @Ryan for me it was the opposite; I found it weird at first because it's unintuitive to uncheck a Silence bell option to silence something. In that case, maybe it's just a toggle; so toggling this checkbox would toggle the behavior from whatever state it's on. Jan 5, 2022 at 21:19
  • 2
    @rrlamichhane, many thanks to you, man! Do you know how it feels like, when there is no sound when I hit the tab key? The silence, it feels great! Thanks a lot. Jan 24, 2022 at 4:14
  • is there a command line settings to configure iterm? don't want to do this on all my macs
    – fabmilo
    Jan 7, 2023 at 3:44
5

Got to:

iTerm2 -> Preferences -> Profiles

Under Terminal tab, you will see Notifications header. Make sure the Silence bell option is Checked enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .