37

I am sure I had same issue with Windows 10 and solved it. Now I can't solve it with Windows 11.

I have English (United Kingdom) language which is also locale language. I don't have English (United States) anywhere - see pictures.

However my keyboard with English UK is US. In Windows 10 it was not a problem - I had only one keyboard (US) with English UK language.

In Windows 11 I have now two keyboards if I use switch shortcut but in the settings there is only one keyboard and I can't delete the second one as it's not there.

To recap: I want to have ENG English (United Kingdom) US keyboard and remove ENG English (United States) US keyboard. All "duplicate" questions are not applicable here because I do not have ENG English (United States) language anywhere in the system.

So again - I need UK English language with US keyboard layout and nothing else.

Removing Preview key from registry doesn't work - it is back as soon as I sign in.

Keyboard layouts when I press Ctrl+Shift

Keyboard layouts when I press Ctrl+Shift

Language settings - only UK

Language settings - only UK

UK Language options

UK Language options

10
  • 2
    Does this answer your question? How to prevent Windows 10 from automatically adding keyboard layouts (i.e. US keyboard)
    – Ramhound
    Commented Oct 8, 2021 at 18:52
  • 1
    Does this answer your question? How to delete a keyboard layout in Windows 10
    – harrymc
    Commented Oct 8, 2021 at 19:41
  • 1
    look at the pictures - I do NOT have ENG US language. So I cant remove it because its not in the settings. But when I press keyboard switching sequence I have 2 keyboards. One for UK Eng language with US layout and one US Eng language with US layout.. I only need one.. Hope that clears it. Thank you Commented Oct 9, 2021 at 15:45
  • 1
    After I remove the layout, is there also a way to prevent it from re-appearing? It feels like it gets added on every windows update.
    – mvlabat
    Commented Apr 30, 2023 at 9:57
  • 1
    I noticed that under Time & language > Language & region > Related settings section, "Administrative language settings" option, "Administrative" tab, "Language for non-Unicode programs" I still had US English (unwanted). Changing this to UK English (using the "Change system locale..." button) seems to have got rid of the US keyboard option.
    – Jon
    Commented Jan 15 at 13:07

5 Answers 5

34

If you have any additional keyboard layout:

enter image description here

That belongs to language that you don't have installed:

enter image description here

Then simply:

  1. Install that language (English (United Kingdom) in the above example)
  2. Go to language details and install the keyboard layout (Polish (Programmers) in here)
  3. Uninstall the whole language language pack

After that pressing Win+Space should reveal only languages and keyboard layouts that you have actually installed in your system.

3
  • 9
    Thanks, this fixed it for me too. So just to clarify for other readers, if you manually add the language + keyboard combination that you want to remove, then after you remove that language, then it will no longer show up.
    – Sam
    Commented Jan 29, 2022 at 19:34
  • I can confirm with the latest update to Windows 11 as of the date of posting this works. Switch to the language you want to REMOVE, let it log out, come back in, switch to the language you want, let it log out and log back in. Then remove the language you want to REMOVE and the taskbar thing disappears.
    – John Stock
    Commented Jul 13, 2023 at 20:16
  • 1
    It comes back after restart, unfortunately. Not sure, what I did wrong Commented Dec 22, 2023 at 0:14
8

I have the same issue with other languages: I have a German Keyboard and a German system but I'm forced to have a US English language layout.

Since I very often press Windows+Space accidentally, I end up changing the layout by accident.

Sadly, I can't remove English as language since my only existing language is German.

However, I found that installing the US language and then removing it, solved it for me.

0
7

This did the trick for me.

Settings or Win+i > Time & language > Typing > Advanced Keyboard settings

Check Use the desktop language bar when it’s available.

Then click Language bar options below, under language bar check Hidden.

1
  • 1
    That's a useful contribution but it doesn't really solve the problem. For example I might want UK English and French keyboards so I might need to have the the language bar visible, I just don't want US English available. Commented Dec 8, 2021 at 14:50
2

In Windows 11 settings (Win+i), select Time & language > Language & region:

  1. Open the Language options of any listed language, press Add a keyboard, select US Qwerty to add it, then click on the triple dots next to US Qwerty and select Remove to remove it.

  2. Related settings section, "Administrative language settings" option, "Administrative" tab, "Language for non-Unicode programs" > press the "Change system locale..." button, replace "US English" with the layout of your main language.

  3. Reboot.

3
  • 2
    it comes back after the next windows restart
    – Zippp
    Commented Aug 17, 2023 at 23:50
  • @Zippp it comes back after some time on my computer too. I found an additional workaround, added it in my answer as point 2, try that. Commented Jan 19 at 17:48
  • point 2 is a must for me. fixed it after restart.. i was going to write an answer but you were already here :)
    – user65535
    Commented Feb 1 at 13:05
1

I had a similar issue on Windows 11. My installed layouts were:

  1. English / US layout
  2. German / DE layout
  3. German / US layout <-- I don't want this!

I want only #1 + #2, but not #3 (German with US layout).

To remove #3, go to Settings (Win+i) > Time & Language > Language & Region. In the "Language" section at the top, there were two entries:

  1. English (United States)
  2. German (Germany) <-- configure this one

enter image description here

Click on the "..." icon next to the "German (Germany)" entry, select "Language Options". On the new page, scroll down to the "Keyboards" section. There were two entries:

  • German QWERTZ
  • German QWERTY (US) <-- remove this

Click on the "..." icon next to the "German QWERTY" entry and select "Remove".

enter image description here (Note: I took this screenshot after the German QWERTY entry was already removed, so it actually shows the desired end state.)

Done!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .