6

I'm having an issue with my macbook pro running OS X 10.6: when I go to create a new folder from the finder the "New Folder" option is completely disabled.

The finder help points to a permissions problem, but when I click on the parent folder and hit permissions I see that I'm the owner (the info box even helpfully says "(me)"), and that I have read and write access.

As a workaround I'm creating folders from the command line using mkdir (with the same account), but I'd like to be able to do this graphically.

Any ideas?

7 Answers 7

1

Do you see this icon in the corner of the window?

nowrite

If so, that does indicate that you can't write to the folder.

You might try running Repair Permissions in Disk Utility (click on the disk, then First Aid > Verify/Repair Disk Permissions).

3
  • That icon is indeed there. I ran repair permissions and it appeared to do a bunch of stuff, but unfortunately the icon remained. I'm going to run "verify permissions" now and see what happens. thanks!
    – Simon
    Jul 29, 2010 at 5:02
  • When you check the permissions via Get Info, try looking at the folder you're trying to create a folder in, not the one above it (unless that's what you were doing...)
    – jtbandes
    Jul 29, 2010 at 5:13
  • I spoke too soon, I ran verify and then fix and it worked! THANKS!!!
    – Simon
    Jul 29, 2010 at 5:41
1

Is this folder on some form of external device? Sometimes you may plug in some device, such as a flash disk or memory card or external hard drive that has one of two circmstances:

1) The device itself is write protected, which means that though you have the "permission" based on Mac permissions, the device itself has been mounted as Read-Only.

2) The device is of a filesystem type not supported for Read-Write by OS X. Again, you can see it, but you won't be able to perform write operations, such as creating a new folder.

2
  • 1
    Oh sorry I wasn't clear - this is my macbook pro's primary hard drive.
    – Simon
    Jul 29, 2010 at 4:26
  • I am using an external HDD that I usually use on Linux so that explains why I'm unable to write to the drive. Do you have any resources as to how I can make it writeable? Apr 25, 2021 at 20:17
0

If you can write to the folder in Terminal as yourself without sudo but not in Finder it sounds like Finder is crashed.

If you run ls -lR $problemfolder what do you see?

1
  • I assume you mean the permissions - they are: drwxr-xr-x and I am the owner of the folder.
    – Simon
    Jul 29, 2010 at 4:25
0

If you are in a tags folder, it won't let you create a folder; but if you go to your Documents and from there access the tag folder you were initially working one, there you can create a new folder.

0

This happened to me as well. I'm not sure if you had the same problem, but I was trying to create a new folder from recents, which is impossible. Click on downloads or some other area to create a folder to see if that fixes it.

0

I had the same problem. I was logged in as my usual user. I selected Get Info. My user had Read & Write access, however directly below Sharing & Permissions it displayed You can read only.

  • I logged out (I selected to NOT reopen programs)
  • Logged in

Once I was logged in I was able to create a New Folder. Hope this helps!

-1

I guess - maybe wrong - the new system allows us to create new folder ONLY after the first layer which has been customized as only 4 folders. You can go one layer down and see the function of creating new folder under which you can create new folder at will. I put all my documents under the user folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.