0

I have a HP Elitedesk 800 G1 SFF with the following specifications:

Processor: Intel Core i5-4570 @ 3.20 GHz

RAM: 8 GB (7.89 usable)

System type: x64

Opersting system: Windows 11

GPU: Radeon RX 550X

I think that's not that bad, but still the PC works very slow (long start up time, applications sometimes take minutes to start up)

Things I already tried:

  • Checking the RAM (no errors found)
  • Check the PC with HP diagnostigs tool (no errors found)
  • Defragment the SSD
  • Using a complete new SSD
  • Antivirus check
  • Disable all start up processes
  • Activate/Deactivate Fast boot
  • Delete junk files

At last I tried to reinstall windows (with keepung the files) ehich increased the performance only a tiny bit. The problem can't be the GPU or Windows 11, because it was like this when I hadn't this GPU and Windows 10 was installed.

I know someone who has the exact same PC with windows and doesn't have Problems.

I ran out of ideas. So does anybody know something I haven't tried already?

5
  • 3
    Ugh! Never defrag an SSD. Your CPU isn't qualified for Win 11, gen 8 is the oldest, so you can expect poor performance - docs.microsoft.com/en-us/windows-hardware/design/minimum/…
    – Tetsujin
    Oct 15, 2021 at 15:41
  • @Tetsujin As I said I had the same performance issues with Windows 10 Oct 15, 2021 at 15:50
  • 1
    It's an 8-year-old not very fast computer with not much memory. You didn't say what the storage sizes are, but it's never going to be lightning-fast… It wasn't fast when it was new. As soon as you're using over 4GB RAM [which in real terms is about 'the OS plus one app'] then you're going to be in paging. Double the RAM, make sure the SSD is at least 256GB, preferably 512 or larger [& investigate what TRIM does & how to run a full TRIM on an older drive.]
    – Tetsujin
    Oct 15, 2021 at 15:57
  • Wouldnt it make sense just to revert back to windows 10 ? 4 more years of support is plenty and you wont have to figure out why a non supported OS is slow on your computer.
    – Silbee
    Oct 15, 2021 at 16:53
  • @Tetsujin The ssd is 931GB big and Trim is already activated Oct 16, 2021 at 5:15

1 Answer 1

0

I know this is 8 months old. But did you ever get a solution for your issue? I purchased this model refurbished from Micro Center and had a similar issue that racked my brain and it ended up being a storage controller driver issue. Even with a fresh Windows 11 install and an SSD. It made no sense. Updating that resolved everything hanging for me. Runs smooth and fast now. It's a generic driver built into Windows you have to update under Device Manager.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .