11

I am aware that this question has been asked before, but none of the solutions work for me.

I have multiple MicroCenter USB 3.1 32GB flash drives that the issue. Originally, they worked, but as soon as I tried to copy multiple files and folders onto them for the first time, they show the error. I also cannot format the disk, as the same error appears

The errors:

Copy to desk

Trying to Format

What I tried:

Running Attributes Disk

Current Read-only State : Yes
Read-only  : No
Boot Disk  : No
Pagefile Disk  : No
Hibernation File Disk  : No
Crashdump Disk  : No
Clustered Disk  : No

Running chkdsk:

The type of the file system is FAT32.
Shadow copying the specified volume is not supported.

Volume USB DISK created 7/11/2021 10:01 AM
Volume Serial Number is BAAD-502B
Windows is verifying files and folders...
File and folder verification is complete.

Windows has scanned the file system and found no problems.
No further action is required.
   30,232,640 KB total disk space.
           16 KB in 1 hidden files.
          432 KB in 27 folders.
   16,421,008 KB in 49 files.
   13,811,168 KB are available.

       16,384 bytes in each allocation unit.
    1,889,540 total allocation units on disk.
      863,198 allocation units available on disk.

In Registry Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies, WriteProtect is set to

Value Data: 0
Base: Hexadecimal

Checking the drive shows the message

You don't need to scan the drive. We haven't found any errors on this drive.

Some other screenshots:

Drive Details

Drive Events - Information

Drive Events - Warning

Edit: I tried removing the cover (Spent a solid 20 minutes on it) but it refuses to budge. It also looks like the actual circuit board is hidden behind a black layer as well. Below are some images of the drive.

enter image description hereenter image description here

9
  • 3
    Does this answer your question? What can I do if my USB flash drive is write-protected or read-only?
    – Tetsujin
    Oct 17 at 17:41
  • 8
    Best guess is they're fakes, first time you write past their actual capacity, the firmware lock kicks in & they're dead. See geckoandfly.com/22803/… for various ways to test them - you'll need to test one that's not already broken.
    – Tetsujin
    Oct 17 at 17:43
  • Thanks @Tetsujin. Since these were free (See blow comment), I think my time may be better spent trying to get them replaced. Oct 17 at 18:59
  • 2
    I suggest you crack one open, and photograph the chips, and add to question. I bet they're really a 1GB or perhaps 4GB drive that has been intentionally modified to mis-report capacity.
    – Criggie
    Oct 18 at 1:58
  • 2
    @Criggie I wouldn't try a hammer, that will probably break things. I'd go with a screwdriver. Oct 19 at 2:40
24

The disks are dead and they never worked. Their working for a short time was only an optical illusion.

If you look in the messages in the Event Viewer, the device is identified as
Device USBSTOR\Disk&Ven_&Prod_USB_DISK_3.0...

Notice that there is no Vendor ID or useful Product ID, meaning that the firmware on the disk is even incapable of identifying itself. This by itself is not unknown with cheap disks, but it only adds to the general air of cheap fakery.

If there is any way of returning these disks and getting reimbursed, don't hesitate. Better avoid this vendor in the future.

9
  • 1
    Lovely, that's what I figured based off of other posts. These were free drives as part of a "Come into the store" campaign (Past drives I got from them for free worked). I think I'll print out this topic and bring it into the store and complain, hopefully they can replace these things with something that works. Thanks for your time! Oct 17 at 18:56
  • 10
    @Tetsujin I wouldn't--I doubt the store meant to give away fake drives. I would tell the store what's happening, though. Oct 18 at 2:03
  • 10
    Micro Center is a reputable store. They are the only bricks and mortar computer store I go to or recommend to anyone. Seriously. I have been extremely satisfied with customer service from them over the years. Show them the problem. I'd bet if you approach them nicely they will swap for replacement flash drives. Oct 18 at 2:33
  • 3
    @manassehkatz-Moving2Codidact And free thumb drives have been their standard giveaways for years. I got an advert a week or two ago with coupons for them.
    – Barmar
    Oct 18 at 4:03
  • 4
    I’m sure it was some sort of accident, I have gotten free ones from them before and they work. It is an amazing store, I’m not going to report them. I will let them know and try to get them replaced though. Oct 18 at 13:22
0

If the device has a functional controller and any amount of functional memory and you can identify their models, it should be possible to reflash the controller using its manufacturer's utility (which would re-detect the actually available memory chips and rescan them for bad blocks, allow to specify heavier ECC for low-quality memory etc). In particular, most such utilities allow to specify the reported vendor and model IDs which are currently not specified as @harrymc noticed.

https://usbdev.ru is the best resource that I know of that has utilities for both identification and flashing. It also has the H2TESTW utility that you can test a new flash drive with for defects (including fake size).


However, as @harrymc said, if you got the drive at a reputable store, it's probably more productive to return or exchange it rather than be stuck with a defective product.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.