0

General info: Windows 11, Office 365, both languages installed in the system as well as in Word.

I use two keyboard layouts (English and Czech), which have completely different punctuation, so even if I write English text, I will mostly want to stay in the Czech layout.

When writing any kind of text in Word, the editor seems to set the language of the text written to that of the current keyboard layout. There are plenty of ways of changing the proofreading language after the text is written, but I have not yet seen a way of changing the default settings so that the text stays in English even if written in a Czech layout.

Is there a way of bypassing this annoying "smart feature" of Word to hardwire the document to be proofread in English regardless of the current keyboard layout?

I have played around with the "Detect language automatically" feature, but it seems to affect only a selected region, which is retrospective by principle.

2 Answers 2

1

You cannot do this. Word will switch language with the keyboard layout.

There is no option setting. VBA will not do what you want.

What you can do is:

  1. Have your operating system language set to the primary language that you use.
  2. Turn off the option in Word to automatically select language.
  3. Have your primary language set as the proofing language in your base styles.
  4. Create and use paragraph and character styles that have the alternative language.
  5. Set keyboard shortcuts for these styles. For character styles, you can use Ctrl+Spacebar to return - to turn off a character style.

Here is a link to my article on Proofing Language troubleshooting on the Micrsoft Answers site.

Here is a link to my article on Assigning Keyboard Shortcuts on the Microsoft Answers site.

0

I've been dealing with this issues for years, and I finally figured it out (Win 10). Go to language settings => Preferred languages => choose the input language you'd like to use for proofing (English) => keyboards Likely, there is only the English keyboard (QUERTY) listed. => Add keyboard => chose the one for Czech.

Now go to Settings => devices => typing => Advanced keyboard settings (at the bottom of the page) => Override for default input method In the drop down list, besides English - US/UK, there should be an entry English - Czech. Choose this, and there you go! Or you can switch between input languages and keyboard layouts by using keyboard shortcuts => Chose input language/method English and keyboard layout (QUERTZ). Hope it works in Win11 as it does in Win10!

1
  • How is this better than accepted answer?
    – Toto
    Mar 10 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.