0

TL;DR: I have a Dell XPS L5112Z that boots perfectly fine after a fresh Windows 10 installation but is stuck at "Operation System not found" after a fresh Ubuntu 20.04 installation.


I have two identical Dell XPS L5112Z laptops. I am trying to install Ubuntu-20.04.3-live-server-amd64 on one of those laptops using a RUFUS 3.17 (ISO-made) USB-stick. I can boot from USB, start the Ubuntu installation and finish it without any problems. Then when I reboot I get a "Operation System not found". Now the worst part, I use an USB Windows installer generated using the Windows 10 Media Creation tool and Windows 10 installed flawlessly and boots without problems. This is pure pain!

Hardware

I read a load of forum posts on this and related and tried most if not all solutions, most are referring to potential hardware failure. So, I tried the same installation with several other hard drives (both SSD and HDD) without any success. All the drives I tried are recognized in the BIOS and in the Ubuntu installer. I tried a setup with LVM group and without, both encrypted and not encrypted. No difference whatsoever. I also did a full physically checkup, took the whole thing apart and put it back together, no physical obvious hardware issues found. I also ran the full built-in Dell diagnostics tool without any issues except a warning on the life of the battery.

BIOS

Also, I noticed the BIOS running was A12 which seemingly isn't downloadable anymore from Dell. I have an identical L5112Z laptop running ZorinOS (Ubuntu based), I checked for any differences in BIOS and I noticed a different version, the Zorin laptop is running bios version A10. The problematic one was running A12. Both A10 and A12 don't seem downloadable anymore. But just to be sure I downgraded the problematic laptop back to A9 (the last downloadable BIOS, https://www.dell.com/support/home/en-uk/product-support/product/xps-15z/drivers). Which also did not solve the issue and did not make any difference. I tried to change the ATA/AHCI options, resetting the BIOS to defaults, clearing the CMOS battery and disconnecting the internal battery. No difference.

Exclude installation media problems

I verified that the downloaded image: MD5: 8df52f27204c37a50a169989fb019188 is correct and with Rufus 3.17 I tried the ISO- and DD-mode when writing to the device. I also tried the installation from two different USB-sticks and from two different USB ports on that laptop. I also tried the Ubuntu installation with and without the HWE kernel. And as suggested by @Robert I also tried specifically the Rufus option "GPT and EUFI (no CMS)" and also I tried the Rufus option "MBR with legacy bios support". Just for the sake of it I did another attempt with the same image using BalenaEtcher instead of Rufus also without success.

Other potential issues?

I am not sure if this laptop is supposed to have a TPM chip and if this can cause any issues but I cannot detect any TPM chip in Windows. I thought of the TPM chip because I recall this laptop very long ago suddenly got Bitlocker issues but maybe that was a Bitlocker setup without TPM at the time. Anyway, the bios is also extremely limited and does not even have a "secure boot" option. I did run other benchmarking and testing tools in Windows 10 on that laptop such as BurnInTest and they only show some warnings on GPU which I think has not much to do with the "No bootable OS detected". Also, GPU seems to work at least normal in the Windows GUI. And I intend to use this laptop CLI only anyway without special GPU need.

I did this whole installation process several times, switching back and forth between Windows and Ubuntu installers and I can't get Ubuntu to boot while Windows boots fine. What can possibly be wrong here? What am I missing? Who has the golden answer?

3
  • I would configure Rufus to GPT and UEFI only just to make sure Linux is bootend and installed in UEFI mode.
    – Robert
    Commented Oct 23, 2021 at 17:31
  • @Robert, it seems that when I make a USB stick like that that the laptop does not pick up the installer at all. It goes straight to "Operating System not found." I did use ISO-mode in Rufus with "GPT and EUFI (no CMS)", I will try the same one more time with DD-mode, just to be sure.
    – Bob Ortiz
    Commented Oct 23, 2021 at 17:39
  • @Robert "GPT and EUFI (no CMS)" using Rufus 3.17 in DD-mode did start the installation. It also did the full install without any warnings but then after a reboot back to "OS not found". I did however very shortly in the beginning of the installation, directly after the integrity check without errors, see a message "/dev/loop2: Can't open blockdev" and "systemd[1]: Failed unmounting /cdrom".
    – Bob Ortiz
    Commented Oct 23, 2021 at 17:53

1 Answer 1

0

This cost me too many hours and thanks to the comment of Robert on the question he did point me to the right direction a possible UEFI issue.

After reading a lot and realizing that the bios A09 has very limited options and that Windows was possibly installed in legacy mode. I decided to dig in further. https://www.itzgeek.com/post/how-to-install-ubuntu-20-04-lts/, the article pointed out to use Universal USB Installer instead of Rufus for the BIOS compatible installation. I tried, it gave me a slightly different installation but again resulted in the same issue. Also the article was based on the graphical installer for the desktop version, not the server version.

Then I found this answer https://askubuntu.com/a/1334617/1173646 which hints even more in the right direction. Apparently there is a "legacy installer" Ubuntu ISO. Strangely enough, because I would expect that the Ubuntu Installer would properly embed an UEFI or Legacy installation option but it did not.

The Legacy Server Ubuntu image can be downloaded here: http://cdimage.ubuntu.com/ubuntu-legacy-server/releases/20.04/release/. I did make a new installation media with Rufus this time specifically specifying MBR partitioning and selecting the "Solutions for old BIOS" option. This gave me a totally different installer and finally solved my issue.


For reference, the BIOS versions A10, A11 and A12 are also downloadable but when searching for drivers only A09 is shown. By clicking on "older versions" near the A09 download button on the Dell site. It doesn't make sense, but here are the direct links:

Important note: A11 and A12 were released on 04 Jun 2020. While A09 seems newer as it is released on 08 Jun 2020 and is also flagged as "latest" on some pages. Totally illogically: A10 was released in 2012! Dell officially sucks.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .