13

I'm trying to ping my Windows 11 machine from a Linux device. Here's what I've tried so far:

  • Disabling Windows Defender Firewall
  • Enabling inbound rules from the Advanced Options
  • Restoring firewall & network settings
  • Uninstalling VPNs

I'm 99% sure the issue is in the Windows machine since they can both ping the router and I can also successfully ping other Windows devices from Linux.

Am I missing something?

Edit: I don't think it's a firewall problem since I can't ping my Windows device regardless of the status of the Defender Firewall.

Edit 2: I don't know if it's related to this problem, but:

  • Ping to localhost: Successful
  • Ping to 127.0.0.1: General failure
  • Ping to 192.168.x.x (Windows IP): Timeout
  • Ping to 192.168.x.x (Other devices): Successful
6
  • Are the Windows 11 and Linux machines connected via a simple switch or via something that can filter packets? Can you ping the Windows 11 machine from other Windows machines? Can you ping the other machines from the Windows 11 machine? Oct 26, 2021 at 14:27
  • Windows connection is wired while Linux is connected through Wi-Fi. I cannot ping Windows from any device while I can ping other hosts (including the router) from the Windows machine.
    – Francesco
    Oct 26, 2021 at 14:59
  • If the subnet mask is set correctly, you could reset TCP/IP. Oct 26, 2021 at 15:07
  • That didn't work. I also updated the question with some interesting outputs of ping commands.
    – Francesco
    Oct 26, 2021 at 17:52
  • You could use Wireshark to see if the ping packets are getting to the W11 machine. Oct 30, 2021 at 8:48

5 Answers 5

19

After poking around I managed to enable ICMP responses on my Windows 11 machine:

Open Windows Defender Firewall and select Advanced Settings in the sidebar. Switch to Inbound Rules via the Getting Started page or the sidebar. Find the rule named "Core Networking Diagnostics - ICMP Echo Request (ICMPv4-In)" with Profile of "Private, Public" (unless you're on a corporate domain...). You can right-click the rule and Enable Rule.

You might also want to do the same for the IPv6 version named "Core Networking Diagnostics - ICMP Echo Request (ICMPv6-In)". I don't know why Microsoft decided to disable these by default.

4
  • 1
    This solved the same issue for me, thanks! Really weird how they decided to leave it disabled all of a sudden, even for networks marked as "Private".
    – olex
    Nov 26, 2021 at 13:33
  • 1
    This worked for me as well. For me, I have a client-server application where the server was Win 11. The client was able to successfully connect to the database on the server but after a while it would freeze up. When it was frozen I noticed I couldn't ping the Win 11 computer. So it is almost as if the Win 11 allowed connections for a bit but then shut off access. This fixed seems to have fixed it for good though. Dec 3, 2021 at 17:27
  • I had to enable the corresponding outbound rules as well, in addition to the inbound rules. Jun 30 at 21:13
  • In my case for Core Networking Diagnostics - Scope for remote address were set local subnet only
    – AlfeG
    Nov 6 at 8:23
4

In addition to Morphit's answer there is an additional option (if you want to use file and printer sharing on your network):

  1. Check your connection classification (private, public, domain).

  2. Go to Control Panel -> Network and Sharing Center -> Change advanced sharing settings. Turn on file and printer sharing, make sure that you choose correct network profile.

This will automatically activate the appropriate rules in Windows Defender Firewall, e.g. File and Printer Sharing (Echo Request - ICMPv4-In). This will have the same effect as activating the rule Core Networking Diagnostics - ICMP Echo Request (ICMPv4-In) directly.

Please note: this will enable people on your LAN to access files and printers if you turned on sharing. If you don't want to use it, go with Morphit's answer.

0

do you have custom IP settings? are linux device and win11 machine on the same subnet? if not, make sure the default gateway in win11 is set correctly

2
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Oct 26, 2021 at 12:51
  • They both have a static IP and are in the same subnet.
    – Francesco
    Oct 26, 2021 at 12:51
0

Look in Start, Settings, Internet and make sure your connection is set to Private. Windows 11 can make Ethernet Public and you need to set this to Private.

(I am on an unsecured network myself right now).

Windows 11 Private Network

Make sure in Advanced Network and Sharing center that Network Discovery is ON for Private Networks.

Windows 11 has made default security more controlled than Windows 10.

Check also in Advanced System Properties and turn on Remote Access connections for this device. Try this - it should not make a difference to Ping.

Windows Firewall should be Default.

I make network settings, firewall settings, and IP addressing to be very much standard or default.

Update (as I am back at my Windows 11 Pro Machine)

I can connect from my Windows 10 machine to my Windows 11 machine and open/copy/paste files (file transfer).

I can Remote Desktop from Windows 10 (Windows RDP) to my Windows 11 machine and that works.

So all that I need to do works.

I cannot ping my Windows 11 machine even though I can do everything else.

To enable Ping. Open an Admin Command prompt.

netsh advFirewall Firewall add rule name="your rule name" protocol=icmpv4:8, any dir=in action=allow

Enable Ping Windows 11

Command to Activate PING in Windows 11 CMD:

netsh advFirewall Firewall add rule name=”Rule name” protocol=icmpv4: 8, any dir=in action=allow

5
  • Still nothing. The home network is recognized as Private, the device is discoverable and printer/file sharing is enabled.
    – Francesco
    Oct 26, 2021 at 11:26
  • Try allowing Remote connections in Advanced System Properties. That should not prevent Ping but try ti. Also try resetting Windows Firewall to default settings.
    – John
    Oct 26, 2021 at 11:31
  • Still getting 100% of packet loss with Remote access connections enabled.
    – Francesco
    Oct 26, 2021 at 12:20
  • I added a section to my answer to enable Ping (off be default). I could already share files and RDP to the Windows 11 machine.
    – John
    Oct 26, 2021 at 23:29
  • Still nothing. I added an interesting section about pinging other hosts from my Windows machine. That may help.
    – Francesco
    Oct 27, 2021 at 7:30
0

If you have McAfee, there's a setting under Firewall > My Network Connections > Edit to make your home router a "Home" network - the default is "Public," and McAfee will not accept ping (or many other net-tools) on Public networks.

2
  • OP says in question that they use “Windows Defender Firewall”
    – Toto
    Feb 16 at 14:52
  • Yes, but after I came here looking for solution and tried messing around with Windows Defender Firewall, I realized that I had McAfee installed over it. Seems like someone else might have the same scenario, so a post in the same thread seemed like it might be helpful.
    – tibbius
    Feb 16 at 23:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.