15

I have just upgraded to Windows 11 on my pc.

As a C++/cmake programmer, I constantly use the option "create new -> text file" on the context menu, but Windows 11 has removed this option.

Is there a way to get this option back, e.g via regedit, or some new tool?

6 Answers 6

4

Load up Regedit, and follow the below steps.

  1. Navigate to HKEY_CURRENT_USER\Software\Classes\CLSID
  2. Right-click the folder and select New > Key
  3. Assign the name {86ca1aa0-34aa-4e8b-a509-50c905bae2a2}
  4. Right-click the new key, and select New > Key
  5. Name it InprocServer32
  6. Edit the default string inside the InprocServer32 key, and set the data to empty/null.
  7. Reboot, and the context-menu should be available.
8
  • Thanks man! Just wondering, should the value in step 6 be "empty/null"? So that the right pane says: Name: (Default) Type: REG_SZ, Data: empty/null ? Or do you mean that it should be blank? Like "" Looks like blank (winaero.com/how-to-enable-full-context-menus-in-windows-11). This actually activates the "full old context menu" right? Jan 28 at 0:05
  • Blank, empty, null, vacant... Jan 28 at 8:02
  • I already have this key as blank in my regedit. I didn't add it. It was there. As a result this answer didn't help me. Instead, running the reg file I downloaded from the link in Markus Knappen Johansson's answer fixed the problem for me.
    – Xtro
    Jun 3 at 18:24
  • 2
    This does not work. I have the "New" context menu but no "New text file" in it.
    – Anixx
    Jun 17 at 21:51
  • 1
    I tried it here and it works.
    – Warren P
    Oct 2 at 23:17
9

What spikey_richie surgests will reset the whole context menu back to the look from Windows 10 which might be what someone wants.

I was looking for a way to only get the "Create New Text Document"-option back. Found this great page: https://www.tenforums.com/tutorials/24412-add-remove-default-new-context-menu-items-windows-10-a.html

And used the "Restore_New_Text_Document_context_menu_item.reg"-file which worked great.

1
  • Thanks. This is the right answer for me.
    – Xtro
    Jun 3 at 18:24
2

Not an answer to the question per se, but a quick work-around:

  1. New > Word Document
  2. Rename it to myfile.txt

Blank word files are just blank files, so this creates a blank file with a .txt extension, as needed.

2
  • Should be the best answer tbh, no need to configure anything though you have to have MS Office installed.
    – Luke Vo
    Jun 15 at 15:38
  • You can also select Rich Text Format, give it a different extension (.txt, .php, etc.) and then delete the one line that the file contains. RTF files are just text files with RTF tags in them. Oct 21 at 7:37
2

If you want to manually change the registry (always make a backup before editing) without resetting it to the Windows 10 look, here are the steps that worked for me:

  1. Open the registry editor and move to HKEY_CLASSES_ROOT\.txt
  2. Add a new Key called ShellNew
  3. Move to the new key (i.e. HKEY_CLASSES_ROOT\.txt\ShellNew)
  4. Add a new String Value with the name NullFile

Now, the only thing missing is the name shown in the context menu. Because it has none per default, the entry does not show up yet. To change this:

  1. Move to HKEY_CLASSES_ROOT\txtfilelegacy
  2. Change the (Default) value to Text File (or any other name you'd like)

Et voilà! It should show up, no reboot needed. (Edit: Maybe you do need to restart explorer.exe, as David Moylan pointed out.) If you want to add a template for the file, this might work, but I did not try it.

1
  • I just tried this but the content menu didn't update. i used task manager to kill and restart explorer.exe and then it appears. obviously a machine restart would also do the same. but thanks - this was the quickest method to set this up. Jun 10 at 3:21
2

What worked for me was resetting the Notepad app -- Settings; Apps; Apps & features; next to "Notepad", select the three dot pop-up menu; Advanced options; select Reset. It appears to effectively do an uninstall/reinstall of notepad and resets the associated settings. "Text Document" has returned as an option under the right-click, New menu.

5
  • This worked for me. Thanks!
    – hsmiths
    Aug 8 at 23:41
  • That doesn't even show up here. No notepad in the list, weird. Aug 28 at 2:38
  • Worked for me as well. Thx!
    – pghcpa
    Sep 5 at 21:34
  • Slight variation worked for me after 22H2 W11 feature update. Menu has changed - no three dot pop-up menu. Select use "set defaults by file type" Select .txt change default app from Notepad to Wordpad, and OK. Then set it back to notepad. Now text file appears in Explorer context menu. Oct 10 at 8:17
  • Didn't work for me. I tried Repair and Reset. Neither worked. Oct 21 at 7:51
-1

Install Windows Notepad from Microsoft Store: https://www.microsoft.com/store/productId/9MSMLRH6LZF3

Then either:

  1. Restart Windows Explorer by going to Task Manager > Processes > Windows Explorer > Right Click > Restart

  2. OR restart windows

and then it should pop up

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.