0

I have a multiport USB-C hub - SATECHI USB-C MULTIPORT V2 (it has some USB-As, a HDMI, a USB-C and a GigaBit Ethernet port). By Windows 10 it is detected as "USB Billboard device" alongside with the Realtek USB GbE Family Controller.

I also have an adapter - USB-C to USB-A (I can confirm with another device that adapter is working).

Using the adapter, I have tested the hub on multiple USB type A 3.0 ports on my computer and it worked\was detected (both directly on the motherboard (ASUS ROG Z370-I), and on the USB hub provided by my monitor (ASUS ROG PG348Q)

After that, I have plugged this hub to the only USB-C port on my motherboard, and it worked there too. But after I have unplugged it from there and now trying to plug the device into USB-A ports (both 3.0 and 2.0), it no longer is detected on these ports. However the blue LED on the hub is on.

If I plug the hub back to the type C port, it is fully operational.

I feel like this is some windows\driver issue, but I am not sure. I am not yet able to test this hub on another computer.

Any advice on how to make this hub work again on USB-A ports?

5
  • You can't adapt USB-A to USB-C, are you sure you have that the right way round? Link to product might help.
    – Tetsujin
    Nov 4, 2021 at 17:51
  • yes, you are right, the adapter plugs into USB-A and has a USB-C port on it. Clarified the question
    – Ubeogesh
    Nov 4, 2021 at 17:53
  • No adapter can convert USB-A to USB-C.
    – harrymc
    Nov 4, 2021 at 20:01
  • @harrymc, there are plenty of passive USBA(plug) to USBC (receptacle) adapters . The only problem is that they work in superspeed mode only in one of cable orientation; if flipped, the port works only as USB2. Depending on quality of wiring/PCB, some of them do work, and are pretty useful. Also there is no technical reason why such adapter cannot deploy a SS-muxer and a CC-controller, to make the C receptacle as fully functional USB-C port. Nov 5, 2021 at 0:10
  • Ubeogesh, try to plug your hub into your A-C adapter in flipped way. Flip the hub captive cable. Nov 5, 2021 at 0:15

1 Answer 1

0

If a hub has a USB-C cable then that is because it needs more than the 9 pins from USB-A to function. USB-C has 24 pins and the adapter, if it does what I believe it does, ignores a dozen or pins on the USB-C plug and therefore disables about half the function of the hub.

In the USB-C and USB 3.c specifications the use of an adapter to connect a USB-C device into a USB-A port is explicitly forbidden. These adapters are forbidden and so have no defined function, which means the people producing them may or may not put in these adapters the means to protect from improper power flow, crossed over data cables, or any of a number of means to wire this adapter which might seem logical but run the possibility of data corruption or damage to hardware.

There is no driver issue. The problem is use of an adapter that is forbidden by the USB spec. Because it is forbidden it has no defined function. As many people will point out it is possible to define a valid function for such an adapter but this will be left inconsistent because it will always and forever still be forbidden by the spec and therefore never behave consistently across devices.

USB-C hubs, docks, and devices are to be only connected to hosts by means of a USB-C port. If your host does not have a USB-C port then find a new host, add a proper USB-C controller, but do not use an adapter to plug a USB-C device into a USB-A port by means of an adapter.

A USB-A hub, dock, or device is permitted to be plugged into a USB-C port on a host by means of an adapter because this is defined in the spec and the intended function of the port. Of course USB-A hubs, docks, and devices can be used on hosts with USB-A ports.

USB-C plugs exist on devices to prevent their use on hosts that lack USB-C because these devices demand more power, more data bandwidth, and/or some alternate mode not available from USB-A. Buying a non-compliant adapter to defeat the protections that USB built into the system runs the risk of corrupted data, damaged hardware, and possibly setting something on fire. You device is not working with this adapter because it was not built to do so. If the device was intended to be used on hosts with USB-A ports then it would have had a USB-A plug to attach to the host computer.

The detection of the device as a "billboard device" is a sign that the wrong cable is being used. In this case there is no right cable, the hub is not compatible with a host computer that lacks USB-C ports.

The adapter you have been using to connect a USB-C hub to a USB-A host should be destroyed before it does permanent damage. Hit it with a hammer until it is broken into unrecognizable and unusable pieces, then discard those pieces. Nothing good can come from the use of that adapter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.