0

Problem: When I join Minecraft, OpenGL errors 1280 and 1282 appear and update graphic driver and reinstall Minecraft 1.17.1, OptiFine but I can't solve this problem ;(

version: 1.17.1

OptiFine: optifine 1.17.1 G9

Shader: complementaryshaders 4.0.2v

OpenGL version : 4.6

latest.log

latest.log

latest.log

OpenGL version

2 Answers 2

0

If you aren't experiencing any actual graphical issues, OpenGL errors are unfortunately kind of normal with OptiFine. I may be slightly off on the exact wording, but you can turn off the error messages under:

Settings > Video Settings > Other > Show OpenGL errors.

If you are experiencing issues beyond the error text, post your full log somewhere?

3
  • latest log frame drop occurs
    – WNG
    Nov 6, 2021 at 3:28
  • Have you tried updating to the latest version of Complementary Shaders? It looks like we're at 4.2.2 now.
    – Aquifel
    Nov 6, 2021 at 3:33
  • I updated the shader but it still occurs errors
    – WNG
    Nov 6, 2021 at 3:53
0

I would recommend two things to solve this issue:

  1. Update ComplementaryShaders to the latest version (v4.2.2)
  2. If the issue still persists, attempt using Iris Shaders instead of OptiFine (This was mentioned in the ComplementaryShaders Project Page)
3
  • This is good, but I want to control shader settings without mod
    – WNG
    Nov 6, 2021 at 4:36
  • Could you specify what you mean by that? You need to use either OptiFine or Iris to load ComplementaryShaders, as stated by their Project Page. Nov 6, 2021 at 6:47
  • This option image Iris Shaders doesn't have this button
    – WNG
    Nov 6, 2021 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.