0

I had mysql-server installed, wordpress was working fine then I tried to install cyberpanel which failed installing mariadb

So I manually tried to install mariadb to know why it failed, it failed again and also broke my mysql, couldn't remove/purge it, couldn't reinstall it either no matter what I did,

After trying a few things here and there including creating backups and removing mysql dirs, now I cannot install anything, culprit being /tmp dir:

apt install x
E: Unable to mkstemp /tmp/clearsigned.message.PdV08H - GetTempFile (74: Bad message)
E: The package lists or status file could not be parsed or opened.

and more interestingly:

ls /tmp
ls: reading directory '/tmp': Bad message

I cannot install something to pull my data like vsftpd will also fail to install

Server is running Ubuntu 20.04

Update: checked dmesg and

EXT4-fs error (device loop0): __ext4_find_entry:1541: inode #2: comm lswsctrl: checksumming directory block 0
8
  • Have you tried to fsck? Compare this question. Nov 6, 2021 at 23:35
  • @kamil tried fsck -y /tmp, no output
    – asim
    Nov 6, 2021 at 23:36
  • What is the output of findmnt -T /tmp? Nov 6, 2021 at 23:44
  • /dev/loop0 on which fsck says cannot continue, aborting @kamil >"/tmp /dev/loop0 ext4 rw,nosuid,nodev,noexec,relatime"<
    – asim
    Nov 6, 2021 at 23:47
  • To fsck ext (aka e2fsck) the filesystem must not be mounted. See man 8 fsck.ext4. That's why the accepted answer to the linked question used a live USB. Before you unmount or reboot, let's investigate what /dev/loop0 is. What is the output of losetup -l /dev/loop0? Nov 6, 2021 at 23:58

1 Answer 1

0

I had the exact same issue, with Kamil's help, and following what is mentioned in this website, I could fix my problem. Just thought others might find it help

2
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Jan 10, 2023 at 23:42
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review Jan 10, 2023 at 23:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .