I ran PsExec on a windows server 2003 32-bit machine to remotely launch a program on a windows server 2003 64-bit machine. The program is a win32 program with dependency to

msvcr80.dll, msvcp80.dll, msjava.dll, PocoFoundation.dll, PocoNet.dll.

The process will freeze and looks like fail to start the user interface.

However, the program was running fine if I log on that 64-bit machine and double click on it. What could be wrong with using PsExec to launch it? I use process explorer but couldn't find anything. Thanks.

EDIT: An update, this issue is actually happening to every program that launch by psexec on that host.

For example, if try to use psexec to launch notepad.exe, I can see the process name (notepad.exe) in task manager, and notepad tab on taskbar. But when click on notepad tab, the window won't show up. It looks like the application stuck in the middle of launching process.

  • Did you tried to use RUN AS instead? – user55183 Nov 10 '10 at 19:54
  • Tried, but not working. Thanks though. – Stan Jan 28 '11 at 22:11

You can not run windows programs and SEE the results. The programs will start and run, but will not display anywhere.

from the Psexec page

... complete with full interactivity for console applications

My emphasis.

  • I see. However, I also use psexec to run a self made windows console program. It does run on some machines, but some others are not working. Those machines are all windows server 2003 VMs, might be created by different templates with different windows updates/hotfix, which I am not sure. And I am guessing different these different updates/hotfix causing the issue. – Stan Jan 29 '11 at 22:49
  • @sgmoore The programs will display on the server if psexec is told to run them in "interactive" mode. – user1686 Mar 8 '12 at 0:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.