0

I can't figure this out and it's become a nightmare.

A computer on our network has no internet. If I plug the problem computer in on another network the internet works. No other computers on the network have a problem. Seems to have happened randomly. Facts and things I've tried:

IP address coming up as 169.254.31.218 while the rest of the network is 192.168.150.xxx

When I ipconfig /release it says: No operation can be performed on Local Area Connection* 9 while it has its media disconnected

Tried: netsh winsock reset catalog, netsh int ipv4 reset reset.log , netsh int ipv6 reset reset.log. Nothing

Tried hard resetting the modem, router, switches, and everything on the network

Any ideas? I'm dying here!

12
  • Tried changing cables, ethernet wall socket [or check the patchbay if it's a large installation]? 'Media disconnected' would tell me it simply can't see a physical connection at all.
    – Tetsujin
    Nov 12, 2021 at 16:56
  • @Tetsujin Tried changing cables, tried plugging into a different port in the switch that works for another computer, same problem....bah! Nov 12, 2021 at 16:59
  • It's super weird, when I changed cables, it worked for ONE SECOND then died and the same thing happened. I feel like the 169.254.31.218 is a big clue somehow... Nov 12, 2021 at 17:00
  • 1
    169.254 is really just shorthand for "I can't find a DHCP server". It gives no hint as to the cause. 'Media disconnected' would imply it's a physical issue. I'd next suspect the NIC, either dirty or bent connections. Can of contact cleaner & a visual inspection, followed by a NIC swap if no joy. If it's a NIC with lights, check it's green.
    – Tetsujin
    Nov 12, 2021 at 17:02
  • Replace the driver for the network card. It is not connecting,
    – John
    Nov 12, 2021 at 17:07

1 Answer 1

0

You have a computer that, when the cable is plugged in does not give you internet access. Instead, you get an 169.254.x.x address. This type of address is automatically generated if no DHCP server can be reached to provide an ip address while the network card is configured to get one. This is done so you can connect two computers together using a cross cable and it will work out of the box.

So, what's going on?

You mention that if you go to another network, it works. This suggests that something is not providing the computer with valid access.

Here is a troubleshoot guide of what you can do.

Step 1: check the lights on the network adapter itself.
When you plugin a good working network cable in a network port on both ends, lights will turn on indicating there is a signal AND there is connectivity. These are a green and orange light. If you have the cable plugged in, but you see no lights, then you have a clear indication that either the network cable is not working, the network cable is not fully plugged in into the card, the network cable is not fully plugged into the other end, or the network device on the other end does not have power and doesn't respond for that reason.

If the lights are not lit, check the cable itself, follow the cable and see where it connects to. See if there are lights on that side and try plugging it out and in or try another port. Try to do anything possible until you see lights. If you see lights but the problem has not been resolved, go to step 2.

Step 2: Plug something else on this cable
If we have lights, but your computer does not get an ip address, plug something else that can do network on this cable and see if that works. Sometimes the configuration may be set such that it should work, but due to some weird thing, now it doesn't. By using another computer or device on this network port, you can confirm whether the problem is on the computer or cable end. If the computer works fine, the first computer has a problem. If it doesn't work either, then the cable has a problem.

I'm going to assume here, given what you have tested so far, that the issue is cable side.

Step 3: follow the cable all the way to the modem
So the cable has lights, but still there is no ip address given, other than 169.254.x.x. Follow the network cable from the computer and see where it leads to. Does it go to a wall socket? Does it go into a switch? Does it go into a router? Does it go to a patch panel? Etc.. Follow its entire path all the way to the modem, so you know what devices are in its path. For each device in its path, see if you see lights on those network interfaces and if there are other devices connected to it and if it works. Check all network cables in between too. Also, make sure that each device in its path has its power connected. I've had an issue where a switch was placed and a cleaning lady had bumped into it, and the power was disconnected.

Step 4: DHCP server config?
Lets assume that all of the above resulted in nothing. The paths seem correct, all lights are lit but the computer still can't get an IP address from the DHCP server. The next step is going to be seeing the DHCP server config. A DHCP server will have a range that it can use to hand out ip addresses. Often, this is from 50 to 150 for example. If the DHCP server has handed out all leases, then the your computer can't receive an IP Address. Similarly, if your computer has a preferred IP address set in the DHCP server, but another computer has its ip address set to fixed to that same address, your ip address is in use and the DHCP server will still assign you that ip address, but your network card can't assign it because of an ip conflict and you get nothing instead.

Step 5: Reboot services that have crashed.
It is also possible that the DHCP server's service has somehow crashed. Given that DHCP will only provide an ipaddress upon a refresh or connect, most devices in the network won't notice this for a long time. The solution is often to restart the service, or in case of a router, restart the router. I know you already did this, this is just mentioned to make the answer a full answer.

There can be more issues, but at this point you have checked all the basic steps that usually provide you with enough information to find out where the problem originates from and find the solution in that area.

2
  • 1
    Thanks so much! Turns out one of the ports on the switch wasn't working properly. Replaced the switch and everything works fine. Dec 7, 2021 at 23:05
  • You're welcome. :) Glad I could help.
    – LPChip
    Dec 8, 2021 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.