I would like to invite everybody to diagnose my computer error for me. I got the following configuration:


  • Motherboard: Intel DG33BU ( 3 years )
  • RAM: A-DATA 1GB DDR2 667MHz x 2 ( 3 years )
  • CPU: Intel C2D E6400 ( 3 years )
  • HDD: Seagate 1TB Barracuda 7200RPM SATA II (bought 1 week ago)

Checking the RAM

The motherboard suddenly sounds 3 long beeps when I switched on my computer this morning. I looked into the documentation and the mighty Google. All redirects me to memory error. To prove my RAM is not faulty, I put it on another known working desktop (with different configurations, of course), the RAM works without problem. Also, I have inserted another pair of Kingston DDR2 533MHz RAM (2 x 1GB, dual channel) into the motherboard. The 3 beeps persist. The culprit is not the RAM.

Checking the CMOS battery

Okay, I moved on to next guy found in Google. He said it might be CMOS battery fault. He tried to remove the battery and do a power cycle. I tried the same. No use. The culprit is not the CMOS battery either.

My Question

So, what is the problem? I know the motherboard is old ( 3 years ), but I believe in Intel's quality. Anyone else encounters similar case?

Please help.

p.s. I don't have enough money to upgrade to i7+DDR3 (my next target)

UPDATE: the same 3 beeps sounded when no RAM is inserted. Obviously it is not about RAM error. Can I be certain that it is a motherboard failure?

  • what BIOS is your motherboard having? – Mr-Right Jul 28 '10 at 10:47
  • I forgot. Since I can't load into BIOS / CMOS ( no video signal ) , they is no way I can know the BIOS version. – Raptor Jul 28 '10 at 13:48

The Intel document on this subject is clear: 3 beeps - Base 64 K memory failure. Reference: http://www.intel.com/support/motherboards/desktop/sb/cs-010249.htm.

If you have verified that the RAM works in another computer, try plugging in only one strip at a time, in different sockets, to see if anything changes. Make sure the RAM is seated properly and the restraining clips fully in place. Some RAM is remarkably difficult to seat properly.

Possibilities: bad socket, bad clip, bad motherboard.

  • Thanks. I have tried different combination placing the RAM. Tried every combination already. All results 3 long beeps. May I ask, what is actually Base 64K memory failure? – Raptor Jul 28 '10 at 13:45
  • "There is a failure of some sort within the first 64 KB of system memory." A PC needs that first chunk of memory to do anything useful, so it's one of the first tests done in the POST. Reference: pcguide.com/ts/x/sys/beep/amiB3-c.html. Have you checked for foreign objects in the memory socket? What about dust? – boot13 Jul 28 '10 at 16:45
  • I have already used a brush to clear all the dusts in the slot (in fact, there is very little chance dust can get into the slot, as the slots are always occupied by RAM). Still 3 beeps. – Raptor Jul 29 '10 at 8:08
  • @Shivan: The best way to clean dust from electronics is with compressed air. You can buy cans of it in electronics stores. As a general rule, you shouldn't touch electronic components with anything that isn't properly grounded. – boot13 Jul 29 '10 at 13:36
  • i see. thanks for the advice. i almost confirmed that the motherboard is dead. – Raptor Jul 29 '10 at 16:21

The solution,I am going to provide is core hardware and physical maintenance,if you can follow the instructions,it needs some technical skills and common-sense.

1st of all de-assembly the motherboard.

Check the problem while motherboard is de-attached from casing.

if problem still exists try to brush up the motherboard with thinner or petrol,and let it dry for about 6 hours in open-air direct sun-light and check the motherboard again.

let me know what ever results you get !!

  • I will try to detach from the casing tonight. thanks & I will let all of you know the latest status. – Raptor Jul 29 '10 at 8:09
  • You're suggesting removing the motherboard from the case, then turning on the computer? And then - if the problem still exists - cleaning the motherboard with gasoline? – boot13 Jul 29 '10 at 13:34

I recently had a similar issue with DZ77RE-75K / i7 processor and I managed to solve it without replacing anything.

The system failed with 3 beeps if I inserted a RAM module on Channel B (Dual Channel Memory). However it booted just fine if I placed the module in one of the Channel A slots. I have four RAM modules (8GBx4) and it used to work earlier. What worked for me was to remove the processor from the motherboard and inspect for any bent pins and carefully place the processor back into the socket and lock it. And it started working with all 4 modules.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.