The Problem

Circumstances have arisen where I have to use VIM on Windows Vista 64bit. I have tried to recreate my Ubuntu Linux set up but all except one of the plugins I have installed are not being recognized by VIM or gVIM. The plugins I installed that I can not get working are:

  • SnipMate
  • FuzzyFinder
  • Surround
  • Matchit
  • Nerdtree
  • MRU

The one plug in that I can get working is:

  • TComment

I should mention that SnipMate, FuzzyFinder, Surround, Matchit and Nerdtree were all .zip files before I extracted them using 7-Zip from the command line. I would do a

7z x plugin.zip -oc:\users\username\.vim

and it seemed to install all the files just like using unzip did on my Linux Ubuntu machine.

The MRU plugin downloaded as a .vim file so I just had to copy it into


TComment was the only one that I downloaded as a .vba.gz file. I had to first unzip it to make the tcomment.vba Vimball file, then edit the tcomment.vba file in VIM and then compile it from source in Vim using

:so %

The Questions

I'm betting my bottom dollar that the reason why TComment works and the .zip form plugins fail is because of how they were installed. Am I right?

Regardless if I am right or wrong, would it be possible on making my current plugins get recognized by VIM and work? If its possible then how to do this?

If it is not possible to make my currently unzipped plugins work again, I would have to redownload the .zip files. Should I use another unzip method besides 7-Zip to get them to work?

And what about mru.vim? All I had to do was copy, or move, it into the plugin directory in my .vim directory. How could that have failed? Am I putting it into the wrong directory?


I have taken screenshots of several important places

  • vim --version output in cmd.exe
  • .vim dire output in cmd.exe
  • .vim\doc dir output in cmd.exe
  • .vim\plugin dir output in cmd.exe

to show you the important version info and plugin installation folder. I also have included screenshot proofs that

  • MRU
  • Fuzzyfinder
  • Nerdtree

VIM commands are not working with in VIM running in cmd.exe as well as including a screenshot of a

  • TComment

VIM command indeed working just fine in VIM running in cmd.exe.

Here is the link to the screenshots at my album called VIM Plugins Issue on Windows Vista VIM

  • Just an FYI: there's a 64-bit build of Vim available at code.google.com/p/vim-win3264. It's not going to help you with this particular problem, but you might like to have it so you can get the shell extension for the "Edit with Vim" context menu item working (assuming that's something you use). Jul 28, 2010 at 12:08

1 Answer 1


Under windows, plugins shall go into $HOME/vimfiles, not into $HOME/.vim

You can move all your files from ~/.vim to the correct ~/vimfiles directory, but don't forget to run :helptags ~/vimfiles/doc as your plugins were not packaged as vimball archives.

  • it worked! thank you so much. you saved me so much frustration. :)
    – classer
    Jul 28, 2010 at 17:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .