I have upgraded to Fedora 35 recently.

While coding on Visual Studio Code, I can't use the Shortcut Ctrl+. to open the quick fix.

When I press Ctrl+. it always display the letter e with the underline. Typing anything more does not work except press Ctrl+. again or press Esc.

I have try to use that key combination in the browser, the terminal when typing to make sure it is not the VSCode problem. And it happens exactly the same.

I have found this shortcut in the Settings but not getting any result.

I still think this is the shortcut problem but don't know how to find which program use that shortcut, which affects the whole system.

Please tell me how to find which program create this shortcut, or is it a bug?

2 Answers 2


The e with an underline lets you insert an emoji by typing its name after the e. Try ctrl+alt+. to bypass this. It worked for me.

  • Sadly. The Ctrl+alt+. does nothing for me. Nov 19, 2021 at 4:04
  • You are right about the emoji. I have figured it out and posted the fix as the answer below. Anyway, I still want to give you the green check because you have shown me the way :) Nov 22, 2021 at 8:00

I still can't fix this, but I found a workaround.

I have changed the editor.action.quickfix keybinding in VSCode to another keybinding to use the VSCode quickfix.


I have figured out that the key combination will trigger the emoji typing on Fedora.

Here are the steps to fix this:

  1. Open ibus-setup
  2. Select Emoji tab
  3. Click on the ... in Emoji Annotation
  4. Change the keycode and the modifiers to anything you want
  5. Click Apply then OK

Now the conflict is gone :)

  • Can confirm that this did the trick for me under Ubuntu 22.04 as well.
    – bluenote10
    Dec 9, 2022 at 14:45
  • 2
    This worked on Ubuntu for me too. There was actually two bindings: CTRL + . and CTRL + ; so I just removed the CTRL + . one. Mar 11 at 4:28
  • Ubuntu 22.04, the ibus-setup thing worked like a charm Aug 3 at 9:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .