I am attempting to add several locations on my disk to my "Favorites" in Windows Explorer. I have used this feature in the 64bit version of Windows 7 without a problem, but it does not seem to work in this install. Here is my methodology so far.

  1. Go to a location in Windows Explorer "C:\users\Benjamin"
  2. Right click on the "favorites" in the left hand folder navigation window and select "Add current location to Favorites"

It does not fire an error, but the location does not appear under favorites. What might be happening here to prevent "favorites" from populating?

  • Do you have administration rights to change settings?
    – random
    Aug 2, 2009 at 1:53
  • Yes, I do. I didn't get any sort of UAC prompt or anything.
    – bsigrist
    Aug 2, 2009 at 3:10

5 Answers 5


The way I did it was to:

  • Navigate to C:\Users\<user>\Links
  • Create shortcuts in there

They appear to be sorted by last-modified in the Favorites list.

  • This works great, thank you so much! I still cannot right click on the favorites and "add current location", but this is a fine workaround... Much better than what I originally proposed.
    – bsigrist
    Aug 16, 2009 at 18:20

The favourites are stored in C:\Users\<user>\Links. So make sure that this directory exists, that you have write permissions, and that the 'read-only' flag is not set.

I was having the same problem, and when I checked read-only was set for some reason. Turning it off fixed the problem.


and easy way is to go to windows explorer, then C:\users(name) click on 'favorites' then right click for 'properties' then at bottom for attributes: unclick 'hidden' and apply then popup asks for all folders and subfolders, click yes and apply, OK all folders correctly show under favorites.


If the folder that you added to favorites didn't appear, simply try to refresh (press F5) and it will appear (you may need to click once on the left pane if that is not in the focus so that it refreshes instead on the right pane which is your folders/files listing).


I had this same issue - and resolved it. When I installed Windows 7 64Bit - I created a Scott.Local user as the on box Administrator. Knowing that I was going to be joining my domain as MYKB\scott.cate. This is a normal setup for me - and when windows joined my domain (after installation of course) I had two sets of users.

  • c:\users\scott.local
  • c:\users\scott.cate

Somehow my c:\users\scott.cate\links directory was deleted.

So I copied the /links directory from c:\users\scott.local to c:\users\scott.cate and the "Favorites" inside Windows Explorer came alive. In the end - this was a case of the /links directory missing from my c:\users{current user name here} directory. I wanted to add my local vs. domain accounts to the story so that might help someone remember to check which account is running.

bottom line - if the favorites in Windows Exlorer aren't working for you - check that the /links directory is valid in current (or possible all of the) user account(s).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .