0

Can't update PopOS 21.04. I've already tried removing all manually added ppa and removing manually installed apps I can think of.

What the heck is going on here? Tried all this...

└─$ apt update

Hit:1 http://apt.pop-os.org/proprietary groovy InRelease Hit:2 http://us.archive.ubuntu.com/ubuntu groovy InRelease Hit:3 http://us.archive.ubuntu.com/ubuntu groovy-security InRelease Hit:4 http://us.archive.ubuntu.com/ubuntu groovy-updates InRelease Hit:5 http://us.archive.ubuntu.com/ubuntu groovy-backports InRelease Hit:6 http://ppa.launchpad.net/system76/pop/ubuntu hirsute InRelease Hit:7 http://ppa.launchpad.net/system76/pop/ubuntu groovy InRelease Reading package lists... Done Building dependency tree Reading state information... Done 25 packages can be upgraded. Run 'apt list --upgradable' to see them.

Ok cool..

└─$ apt upgrade

Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages have been kept back: apt apt-utils fwupd-signed libapt-pkg6.0 libegl-mesa0 libgbm1 libglapi-mesa libglapi-mesa:i386 libglx-mesa0 libglx-mesa0:i386 0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.

Okay you clown... Another:

└─$ sudo aptitude upgrade

Resolving dependencies... No packages will be installed, upgraded, or removed. 0 packages upgraded, 0 newly installed, 0 to remove and 25 not upgraded. Need to get 0 B of archives. After unpacking 0 B will be used.

Ok screw it!! Another:

└─$ sudo apt-get --with-new-pkgs upgrade

Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages have been kept back: apt apt-utils fwupd-signed libapt-pkg6.0 libegl-mesa0 libgbm1 libglapi-mesa libglapi-mesa:i386 libglx-mesa0 libglx-mesa0:i386 0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.

Ugh. Another:

└─$ apt install apt apt-utils fwupd-signed libapt-pkg6.0 libegl-mesa0 libgbm1 libglapi-mesa libglapi-mesa:i386 libglx-mesa0 libglx-mesa0:i386

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: apt : Depends: adduser but it is not going to be installed Recommends: ca-certificates but it is not going to be installed dictionaries-common : Depends: debconf (>= 1.5.5) but it is not going to be installed or debconf-2.0 Depends: libtext-iconv-perl but it is not going to be installed fwupd : Depends: libcurl3-gnutls (>= 7.63.0) but it is not going to be installed Depends: libfwupd2 (>= 1.5.11-0ubuntu2pop1~1627329462~21.04~3e64f3f) but it is not going to be installed Depends: libfwupdplugin1 (>= 1.5.11-0ubuntu2pop1~1627329462~21.04~3e64f3f) but it is not going to be installed Depends: libglib2.0-0 (>= 2.67.3) but 2.66.1-2ubuntu0.2 is to be installed Depends: libgusb2 (>= 0.3.5) but 0.3.4-0.2 is to be installed Depends: libjcat1 (>= 0.1.3) but it is not going to be installed Depends: libtss2-esys-3.0.2-0 (>= 2.3.1) but it is not installable Recommends: python3 but it is not going to be installed Recommends: dbus Recommends: secureboot-db but it is not going to be installed Recommends: udisks2 libglx-mesa0 : Depends: libgl1-mesa-dri but it is not going to be installed libglx-mesa0:i386 : Depends: libgl1-mesa-dri:i386 but it is not going to be installed libgssapi-krb5-2:i386 : Depends: libkrb5-3:i386 (= 1.17-10ubuntu0.1) but it is not going to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Is there a way to fix this without hosing the entire install? I haven't even installed that much or been using it very heavily, it's a fairly new laptop - a little disappointing but I'd rather try fighting this one out a little more than re-install anything.

Edit for requested info (sorry I don't know why the font is huge):

$ cat sources.list

See sources.list(5) for more information, especialy

Remember that you can only use http, ftp or file URIs

CDROMs are managed through the apt-cdrom tool.

deb cdrom:[Pop_OS 20.10 Groovy Gorilla - Release amd64 (20210510)]/ groovy main restricted

deb cdrom:[Pop_OS 20.10 Groovy Gorilla - Release amd64 (20210510)]/ stable main restricted

deb cdrom:[Pop_OS 20.10 Groovy Gorilla - Release amd64 (20210510)]/ unstable main restricted

Commented out but there are 4 files inside the directory:

$ cat pop-os-apps.sources X-Repolib-Name: Pop_OS Applications Enabled: yes Types: deb URIs: http://apt.pop-os.org/proprietary Suites: groovy Components: main

$ cat system.sources X-Repolib-Name: Pop_OS System Sources Enabled: yes Types: deb deb-src URIs: http://us.archive.ubuntu.com/ubuntu/ Suites: groovy groovy-security groovy-updates groovy-backports Components: main restricted universe multiverse X-Repolib-Default-Mirror: http://us.archive.ubuntu.com/ubuntu/

$ cat system76-ubuntu-pop-groovy.list deb http://ppa.launchpad.net/system76/pop/ubuntu/ groovy main deb-src http://ppa.launchpad.net/system76/pop/ubuntu/ groovy main

$ cat pop-os-ppa.list

This file was generated by pop-upgrade

X-Repolib-Name: Pop_OS PPA deb http://ppa.launchpad.net/system76/pop/ubuntu hirsute main deb-src

http://ppa.launchpad.net/system76/pop/ubuntu hirsute main

Edit #2: I commented out all 'groovy' references. For the pop-os-apps.sources and system.sources, I replaced them with identical lines but with 'hirsute' instead. Still looks scary:

└─$ apt update Get:1 http://us.archive.ubuntu.com/ubuntu hirsute InRelease [269 kB] Hit:2 http://ppa.launchpad.net/system76/pop/ubuntu hirsute InRelease Get:3 http://us.archive.ubuntu.com/ubuntu hirsute-security InRelease [110 kB] Get:4 http://apt.pop-os.org/proprietary hirsute InRelease [8,441 B] Get:5 http://us.archive.ubuntu.com/ubuntu hirsute-updates InRelease [115 kB] Get:6 http://us.archive.ubuntu.com/ubuntu hirsute-backports InRelease [101 kB] Get:7 http://us.archive.ubuntu.com/ubuntu hirsute/main Sources [1,316 kB] Get:8 http://apt.pop-os.org/proprietary hirsute/main all Packages [608 B] Get:9 http://us.archive.ubuntu.com/ubuntu hirsute/restricted Sources [16.8 kB] Get:10 http://us.archive.ubuntu.com/ubuntu hirsute/universe Sources [17.0 MB] Get:11 http://apt.pop-os.org/proprietary hirsute/main amd64 Packages [4,600 B] Get:12 http://us.archive.ubuntu.com/ubuntu hirsute/multiverse Sources [285 kB] Get:13 http://us.archive.ubuntu.com/ubuntu hirsute/main amd64 Packages [1,394 kB] Get:14 http://us.archive.ubuntu.com/ubuntu hirsute/main i386 Packages [1,025 kB] Get:15 http://us.archive.ubuntu.com/ubuntu hirsute/main Translation-en [511 kB] Get:16 http://us.archive.ubuntu.com/ubuntu hirsute/main amd64 DEP-11 Metadata [469 kB] Get:17 http://us.archive.ubuntu.com/ubuntu hirsute/main DEP-11 48x48 Icons [102 kB] Get:18 http://us.archive.ubuntu.com/ubuntu hirsute/main DEP-11 64x64 Icons [157 kB] Get:19 http://us.archive.ubuntu.com/ubuntu hirsute/main DEP-11 64x64@2 Icons [15.8 kB] Get:20 http://us.archive.ubuntu.com/ubuntu hirsute/main DEP-11 128x128 Icons [345 kB] Get:21 http://us.archive.ubuntu.com/ubuntu hirsute/main amd64 c-n-f Metadata [29.5 kB] Get:22 http://us.archive.ubuntu.com/ubuntu hirsute/restricted i386 Packages [20.3 kB] Get:23 http://us.archive.ubuntu.com/ubuntu hirsute/restricted amd64 Packages [78.0 kB] Get:24 http://us.archive.ubuntu.com/ubuntu hirsute/restricted Translation-en [12.0 kB] Get:25 http://us.archive.ubuntu.com/ubuntu hirsute/restricted amd64 c-n-f Metadata [436 B] Get:26 http://us.archive.ubuntu.com/ubuntu hirsute/universe amd64 Packages [13.2 MB] Get:27 http://us.archive.ubuntu.com/ubuntu hirsute/universe i386 Packages [7,087 kB] Get:28 http://us.archive.ubuntu.com/ubuntu hirsute/universe Translation-en [5,441 kB] Get:29 http://us.archive.ubuntu.com/ubuntu hirsute/universe amd64 DEP-11 Metadata [3,848 kB] Get:30 http://us.archive.ubuntu.com/ubuntu hirsute/universe DEP-11 48x48 Icons [3,338 kB] Get:31 http://us.archive.ubuntu.com/ubuntu hirsute/universe DEP-11 64x64 Icons [8,115 kB] Get:32 http://us.archive.ubuntu.com/ubuntu hirsute/universe DEP-11 64x64@2 Icons [57.1 kB] Get:33 http://us.archive.ubuntu.com/ubuntu hirsute/universe DEP-11 128x128 Icons [14.6 MB] Get:34 http://us.archive.ubuntu.com/ubuntu hirsute/universe amd64 c-n-f Metadata [279 kB]
Get:35 http://us.archive.ubuntu.com/ubuntu hirsute/multiverse amd64 Packages [206 kB]
Get:36 http://us.archive.ubuntu.com/ubuntu hirsute/multiverse i386 Packages [109 kB]
Get:37 http://us.archive.ubuntu.com/ubuntu hirsute/multiverse Translation-en [108 kB]
Get:38 http://us.archive.ubuntu.com/ubuntu hirsute/multiverse amd64 DEP-11 Metadata [47.3 kB]
Get:39 http://us.archive.ubuntu.com/ubuntu hirsute/multiverse DEP-11 48x48 Icons [29.6 kB]
Get:40 http://us.archive.ubuntu.com/ubuntu hirsute/multiverse DEP-11 64x64 Icons [198 kB]
Get:41 http://us.archive.ubuntu.com/ubuntu hirsute/multiverse DEP-11 64x64@2 Icons [214 B]
Get:42 http://us.archive.ubuntu.com/ubuntu hirsute/multiverse DEP-11 128x128 Icons [307 kB]
Get:43 http://us.archive.ubuntu.com/ubuntu hirsute/multiverse amd64 c-n-f Metadata [8,124 B]
Get:44 http://us.archive.ubuntu.com/ubuntu hirsute-security/restricted Sources [14.3 kB]
Get:45 http://us.archive.ubuntu.com/ubuntu hirsute-security/universe Sources [20.1 kB]
Get:46 http://us.archive.ubuntu.com/ubuntu hirsute-security/main Sources [85.6 kB]
Get:47 http://us.archive.ubuntu.com/ubuntu hirsute-security/multiverse Sources [3,280 B]
Get:48 http://us.archive.ubuntu.com/ubuntu hirsute-security/main amd64 Packages [293 kB]
Get:49 http://us.archive.ubuntu.com/ubuntu hirsute-security/main i386 Packages [116 kB]
Get:50 http://us.archive.ubuntu.com/ubuntu hirsute-security/main Translation-en [73.7 kB]
Get:51 http://us.archive.ubuntu.com/ubuntu hirsute-security/main amd64 DEP-11 Metadata [9,672 B]
Get:52 http://us.archive.ubuntu.com/ubuntu hirsute-security/main DEP-11 48x48 Icons [7,781 B]
Get:53 http://us.archive.ubuntu.com/ubuntu hirsute-security/main DEP-11 64x64 Icons [19.5 kB]
Get:54 http://us.archive.ubuntu.com/ubuntu hirsute-security/main DEP-11 64x64@2 Icons [29 B]
Get:55 http://us.archive.ubuntu.com/ubuntu hirsute-security/main DEP-11 128x128 Icons [32.9 kB]
Get:56 http://us.archive.ubuntu.com/ubuntu hirsute-security/main amd64 c-n-f Metadata [4,696 B]
Get:57 http://us.archive.ubuntu.com/ubuntu hirsute-security/restricted amd64 Packages [233 kB]
Get:58 http://us.archive.ubuntu.com/ubuntu hirsute-security/restricted i386 Packages [22.0 kB]
Get:59 http://us.archive.ubuntu.com/ubuntu hirsute-security/restricted Translation-en [32.5 kB]
Get:60 http://us.archive.ubuntu.com/ubuntu hirsute-security/restricted amd64 c-n-f Metadata [508 B]
Get:61 http://us.archive.ubuntu.com/ubuntu hirsute-security/universe amd64 Packages [227 kB]
Get:62 http://us.archive.ubuntu.com/ubuntu hirsute-security/universe i386 Packages [195 kB]
Get:63 http://us.archive.ubuntu.com/ubuntu hirsute-security/universe Translation-en [48.6 kB]
Get:64 http://us.archive.ubuntu.com/ubuntu hirsute-security/universe amd64 DEP-11 Metadata [5,668 B]
Get:65 http://us.archive.ubuntu.com/ubuntu hirsute-security/universe DEP-11 48x48 Icons [7,654 B]
Get:66 http://us.archive.ubuntu.com/ubuntu hirsute-security/universe DEP-11 64x64 Icons [9,140 B]
Get:67 http://us.archive.ubuntu.com/ubuntu hirsute-security/universe DEP-11 64x64@2 Icons [29 B]
Get:68 http://us.archive.ubuntu.com/ubuntu hirsute-security/universe DEP-11 128x128 Icons [7,417 B]
Get:69 http://us.archive.ubuntu.com/ubuntu hirsute-security/universe amd64 c-n-f Metadata [5,572 B]
Get:70 http://us.archive.ubuntu.com/ubuntu hirsute-security/multiverse i386 Packages [1,704 B]
Get:71 http://us.archive.ubuntu.com/ubuntu hirsute-security/multiverse amd64 Packages [3,372 B]
Get:72 http://us.archive.ubuntu.com/ubuntu hirsute-security/multiverse Translation-en [828 B]
Get:73 http://us.archive.ubuntu.com/ubuntu hirsute-security/multiverse amd64 c-n-f Metadata [220 B]
Get:74 http://us.archive.ubuntu.com/ubuntu hirsute-updates/multiverse Sources [8,384 B]
Get:75 http://us.archive.ubuntu.com/ubuntu hirsute-updates/restricted Sources [14.2 kB]
Get:76 http://us.archive.ubuntu.com/ubuntu hirsute-updates/main Sources [154 kB]
Get:77 http://us.archive.ubuntu.com/ubuntu hirsute-updates/universe Sources [49.1 kB]
Get:78 http://us.archive.ubuntu.com/ubuntu hirsute-updates/main i386 Packages [210 kB]
Get:79 http://us.archive.ubuntu.com/ubuntu hirsute-updates/main amd64 Packages [427 kB]
Get:80 http://us.archive.ubuntu.com/ubuntu hirsute-updates/main Translation-en [111 kB]
Get:81 http://us.archive.ubuntu.com/ubuntu hirsute-updates/main amd64 DEP-11 Metadata [97.9 kB]
Get:82 http://us.archive.ubuntu.com/ubuntu hirsute-updates/main DEP-11 48x48 Icons [27.0 kB]
Get:83 http://us.archive.ubuntu.com/ubuntu hirsute-updates/main DEP-11 64x64 Icons [53.4 kB]
Get:84 http://us.archive.ubuntu.com/ubuntu hirsute-updates/main DEP-11 64x64@2 Icons [29 B]
Get:85 http://us.archive.ubuntu.com/ubuntu hirsute-updates/main DEP-11 128x128 Icons [114 kB]
Get:86 http://us.archive.ubuntu.com/ubuntu hirsute-updates/main amd64 c-n-f Metadata [7,892 B]
Get:87 http://us.archive.ubuntu.com/ubuntu hirsute-updates/restricted amd64 Packages [235 kB]
Get:88 http://us.archive.ubuntu.com/ubuntu hirsute-updates/restricted i386 Packages [22.0 kB]
Get:89 http://us.archive.ubuntu.com/ubuntu hirsute-updates/restricted Translation-en [32.8 kB]
Get:90 http://us.archive.ubuntu.com/ubuntu hirsute-updates/restricted amd64 c-n-f Metadata [504 B]
Get:91 http://us.archive.ubuntu.com/ubuntu hirsute-updates/universe amd64 Packages [343 kB]
Get:92 http://us.archive.ubuntu.com/ubuntu hirsute-updates/universe i386 Packages [244 kB]
Get:93 http://us.archive.ubuntu.com/ubuntu hirsute-updates/universe Translation-en [85.2 kB]
Get:94 http://us.archive.ubuntu.com/ubuntu hirsute-updates/universe amd64 DEP-11 Metadata [57.7 kB]
Get:95 http://us.archive.ubuntu.com/ubuntu hirsute-updates/universe DEP-11 48x48 Icons [25.4 kB]
Get:96 http://us.archive.ubuntu.com/ubuntu hirsute-updates/universe DEP-11 64x64 Icons [40.4 kB]
Get:97 http://us.archive.ubuntu.com/ubuntu hirsute-updates/universe DEP-11 64x64@2 Icons [29 B]
Get:98 http://us.archive.ubuntu.com/ubuntu hirsute-updates/universe DEP-11 128x128 Icons [81.0 kB]
Get:99 http://us.archive.ubuntu.com/ubuntu hirsute-updates/universe amd64 c-n-f Metadata [7,848 B]
Get:100 http://us.archive.ubuntu.com/ubuntu hirsute-updates/multiverse i386 Packages [2,384 B]
Get:101 http://us.archive.ubuntu.com/ubuntu hirsute-updates/multiverse amd64 Packages [7,356 B]
Get:102 http://us.archive.ubuntu.com/ubuntu hirsute-updates/multiverse Translation-en [2,196 B]
Get:103 http://us.archive.ubuntu.com/ubuntu hirsute-updates/multiverse amd64 DEP-11 Metadata [940 B]
Get:104 http://us.archive.ubuntu.com/ubuntu hirsute-updates/multiverse DEP-11 48x48 Icons [1,865 B]
Get:105 http://us.archive.ubuntu.com/ubuntu hirsute-updates/multiverse DEP-11 64x64 Icons [2,498 B]
Get:106 http://us.archive.ubuntu.com/ubuntu hirsute-updates/multiverse DEP-11 64x64@2 Icons [29 B]
Get:107 http://us.archive.ubuntu.com/ubuntu hirsute-updates/multiverse DEP-11 128x128 Icons [29 B]
Get:108 http://us.archive.ubuntu.com/ubuntu hirsute-updates/multiverse amd64 c-n-f Metadata [440 B]
Get:109 http://us.archive.ubuntu.com/ubuntu hirsute-backports/universe Sources [2,516 B]
Get:110 http://us.archive.ubuntu.com/ubuntu hirsute-backports/main amd64 c-n-f Metadata [112 B]
Get:111 http://us.archive.ubuntu.com/ubuntu hirsute-backports/restricted amd64 c-n-f Metadata [120 B]
Get:112 http://us.archive.ubuntu.com/ubuntu hirsute-backports/universe i386 Packages [2,608 B]
Get:113 http://us.archive.ubuntu.com/ubuntu hirsute-backports/universe amd64 Packages [3,708 B]
Get:114 http://us.archive.ubuntu.com/ubuntu hirsute-backports/universe Translation-en [1,252 B]
Get:115 http://us.archive.ubuntu.com/ubuntu hirsute-backports/universe amd64 DEP-11 Metadata [9,348 B]
Get:116 http://us.archive.ubuntu.com/ubuntu hirsute-backports/universe DEP-11 48x48 Icons [29 B]
Get:117 http://us.archive.ubuntu.com/ubuntu hirsute-backports/universe DEP-11 64x64 Icons [1,788 B]
Get:118 http://us.archive.ubuntu.com/ubuntu hirsute-backports/universe DEP-11 64x64@2 Icons [29 B]
Get:119 http://us.archive.ubuntu.com/ubuntu hirsute-backports/universe DEP-11 128x128 Icons [29 B]
Get:120 http://us.archive.ubuntu.com/ubuntu hirsute-backports/universe amd64 c-n-f Metadata [176 B]
Get:121 http://us.archive.ubuntu.com/ubuntu hirsute-backports/multiverse amd64 c-n-f Metadata [120 B]
Fetched 84.3 MB in 8s (11.1 MB/s)
Reading package lists... Done Building dependency tree Reading state information... Done 1255 packages can be upgraded. Run 'apt list --upgradable' to see them.

apt upgrade shows huge changes ending with this:

The following packages will be DOWNGRADED: gnome-control-center gnome-control-center-data gnome-control-center-faces 1246 upgraded, 57 newly installed, 3 downgraded, 0 to remove and 9 not upgraded. Need to get 1,067 MB/1,084 MB of archives. After this operation, 514 MB of additional disk space will be used. Do you want to continue? [Y/n] n

Edit 3: After reversing course back to groovy and removing hirsute, this looks better (I think)?

└─$ apt upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages were automatically installed and are no longer required: gnome-shell-extension-cosmic-dock libpugixml1v5 libqalculate21 libqalculate21-data pop-cosmic pop-launcher qalc touchegg yaru-theme-gnome-shell Use 'sudo apt autoremove' to remove them. The following NEW packages will be installed:
gnome-shell-extension-alt-tab-raise-first-window gnome-shell-extension-always-show-workspaces gnome-shell-extension-pop-shop-details linux-headers-5.11.0-7620
linux-headers-5.11.0-7620-generic linux-image-5.11.0-7620-generic linux-modules-5.11.0-7620-generic linux-modules-extra-5.11.0-7620-generic python3-distro-info python3-distupgrade python3-update-manager The following packages will be upgraded: debconf debconf-i18n ubuntu-release-upgrader-core update-manager-core The following packages will be DOWNGRADED:
accountsservice amd-ppt-bin appstream-data-pop appstream-data-pop-icons com.github.donadigo.eddy firmware-manager-notify firmware-manager-shared gdm3 gir1.2-accountsservice-1.0 gir1.2-gdm-1.0 gir1.2-mutter-7 gnome-online-accounts gnome-settings-daemon gnome-settings-daemon-common gnome-shell gnome-shell-common gnome-shell-extension-desktop-icons-ng gnome-shell-extension-prefs gnome-shell-extension-system76-power gnome-terminal gnome-terminal-data hidpi-daemon kernelstub libaccountsservice0 libegl-mesa0 libfirmware-manager libfwupd2 libgbm1 libgdm1 libgl1-mesa-dri libgl1-mesa-dri:i386 libglapi-mesa libglapi-mesa:i386 libglx-mesa0 libglx-mesa0:i386 libgoa-1.0-0b libgoa-1.0-common libgoa-backend-1.0-1 libmutter-7-0 libnss-systemd libnvidia-cfg1-470 libnvidia-common-470 libnvidia-compute-470 libnvidia-compute-470:i386 libnvidia-decode-470 libnvidia-decode-470:i386 libnvidia-encode-470
libnvidia-encode-470:i386 libnvidia-extra-470 libnvidia-fbc1-470 libnvidia-fbc1-470:i386 libnvidia-gl-470 libnvidia-gl-470:i386 libnvidia-ifr1-470 libnvidia-ifr1-470:i386 libpam-systemd
libpop-desktop-widget libpop-theme-switcher libpop-upgrade-gtk libs76-hidpi-widget libsystemd0 libudev1 libxatracker2 linux-firmware linux-generic linux-headers-generic linux-image-generic linux-libc-dev linux-system76 mesa-va-drivers mesa-vdpau-drivers mesa-vulkan-drivers mesa-vulkan-drivers:i386 mutter-common nautilus-extension-gnome-terminal
network-manager-config-connectivity-pop nvidia-compute-utils-470 nvidia-dkms-470 nvidia-driver-460 nvidia-driver-470 nvidia-kernel-common-470 nvidia-kernel-source-470 nvidia-utils-470
plymouth-theme-pop-basic pop-default-settings pop-desktop pop-fonts pop-gnome-initial-setup pop-gnome-shell-theme pop-gtk-theme pop-icon-theme pop-session pop-shell pop-shell-plugin-system76-power pop-shell-shortcuts pop-shop pop-sound-theme pop-theme pop-transition pop-upgrade pop-wallpapers popsicle popsicle-gtk python3-repolib repoman sessioninstaller system76-acpi-dkms system76-dkms system76-driver system76-firmware-daemon system76-io-dkms system76-oled system76-power system76-wallpapers systemd systemd-sysv systemd-timesyncd ubuntu-drivers-common udev xserver-xorg-video-nvidia-470 4 upgraded, 11 newly installed, 120 downgraded, 0 to remove and 0 not upgraded. Need to get 737 MB/738 MB of archives. After this operation, 330 MB of additional disk space will be used. Do you want to continue? [Y/n] n

1 Answer 1

1

Remove hirsute from your /etc/apt/sources.list or the files under /etc/apt/sources.list.d/, then run:

sudo apt update
sudo apt dist-upgrade
10
  • Oh! So somehow I have conflicting repos in there? But wouldn't I want to remove Groovy since hirsute matches my PopOS version and groovy is older? A list I found says: 21.10 impish, 21.04 hirsute, 20.10 groovy, 20.04 focal
    – Manius
    Nov 21, 2021 at 19:19
  • Oh, I just noticed all the rest say groovy too so I guess your suggestion is probably right. Will give this a try. (Unfortunately this is a different PC so I can't paste sources.list here.)
    – Manius
    Nov 21, 2021 at 19:31
  • sources.list only has 'groovy' stuff in it, although it's all commented out
    – Manius
    Nov 21, 2021 at 19:36
  • Ok I managed to get the contents of sources.list and the files inside sources.list.d directory as an edit. Switching to hirsute seems like I'd be removing a lot of stuff though, do I need to just comment out all the groovy stuff?
    – Manius
    Nov 21, 2021 at 19:48
  • 1
    Pulled the trigger on the last. It looked good almost to completion, but of course now I'm getting some "temporary failure resolving 'apt.pop-os.org'.. hoping it's just some temp server issue. I think at least I'm pointed in the right direction now, anyway. I had no idea this type of situation of conflicting repos could even happen without some more obvious alert. It must have been a failed upgrade from a while ago. Thanks!
    – Manius
    Nov 21, 2021 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.