14

How can I force Chrome to search google.co.uk in the search bar, rather than google.com?

I have tried the following several times with no success:

  • go to google.com
  • click on 'Go to Google UK'
  • do a search
  • restart Chrome

Like I say, the above doesn't work. I've also tried resetting all Chrome's language options to UK English and restarting the browser. I am actually in the UK, and not using a proxy.

What can I do?

Thanks!

4 Answers 4

7

2018 answer, pulled from Google's docs:

  1. On your computer, open Chrome.
  2. At the top right, click More More and then Settings.
  3. Under "Search engine," click Manage search engines.
  4. Find "Other search engines."
    • Add: To the right of "Other search engines," click Add. Fill out the text fields and click Add.
    • Set as default: To the right of the search engine, click More (3 dots) > More and then Make default.
    • Edit: To the right of the search engine, click More (3 dots) > More and then Edit.
    • Delete: To the right of the search engine, click More (3 dots) > More and then Remove from list.

So to add Google UK's search engine, the entry I used had "Google UK" as the Search engine, "google.co.uk" as the keyword, and "https://www.google.co.uk/search?&q=%s" as the URL.

6

If JNK's answer didn't do the trick, make sure you're using https://www.google.co.uk/search?q=%s for the URL. So, the full procedure is:

  1. Right click the URL box at the top of any Google Chrome window.
  2. Click Edit Search Engines…
  3. Click the Add… button.
  4. Set the name to whatever you want (e.g. "Google UK").
  5. Set the keyword to whatever you want (e.g. "uk").
  6. Set the URL to https://www.google.co.uk/search?q=%s.
  7. Click the Add button.
  8. Click the Make Default button.
3
  • This suggestion no longer works due to updates in Chrome. Jun 4, 2018 at 20:47
  • This worked for me today. I'm traveling in Poland and was getting google.pl results from my address bar searches. Doing this with google.com (instead of .co.uk) worked perfectly. Oct 18, 2018 at 20:53
  • Above works if you change URL in step 6 to "google.co.uk/search?&q=%s"
    – DaBozUK
    Sep 27, 2022 at 10:00
4

Go to settings (the wrench on the right)

-> Options

-> Default Search - click "Manage"

-> "Add" button at the top

-> Fill out the info, putting google.co.uk as the keyword

-> You may need to copy the URL from the default google entry.

Enjoy!

2
  • 1
    This breaks search suggestions for me. It will only show queries I've previously searched for, but no other suggestions.
    – Jo Liss
    Apr 28, 2016 at 17:14
  • This suggestion no longer works due to updates in Chrome. Jun 4, 2018 at 20:47
2

None of the answers above worked for me in the latest update of Chrome (October 2018) except the following:

In Chrome under Options (the wrench) go to Default Search -> Manage In the new window fill in the boxes as follows:

Name: Google.XX
Keyword: Google.XX
URL: http://www.google.XX/search?q=%s ** where XX is the specified country, in my case I used .ca for Canada

from https://ccm.net/forum/affich-14111-how-to-change-from-google-xx-to-google-com

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .