4

In Windows XP I can very easily map a network drive to the root of my NAS server. I browse to it in Explorer (\\192.168.1.70), choose "Map Network Drive", then choose the drive letter.

In Windows Vista, mapping the root of a server doesn't seem possible. I have to go "Map Network Drive" from 'Computer', then enter the address, but it will only let me map to specific shares (sub-folders off of the server root) and NOT to the server root share.

Since my NAS has built-in shares (music, photo, video, etc.) then I would have to have drive letters for all of these, which I absolutely don't want.

Why can I easily map a network drive to the server root in Windows XP, but not in Vista? Is there something fundamentally different in the networking across the two OS's? Or do I need to do things a different way?

migrated from stackoverflow.com Jul 28 '10 at 21:40

This question came from our site for professional and enthusiast programmers.

  • As far as I'm aware, Vista makes it illegal to access a share without a full path (host + share). – user3463 Jul 29 '10 at 2:02
  • Aren't administrative shares available in Vista? \\192.168.0.2\c$ May need professional version or some other hack to get it working. To get it working in my Win8 & Win10 LAN I had to make a registry change. Not familiar with Vista, sorry. – adampski Nov 16 '15 at 18:16
  • I believe this issue is still present in Windows Vista, 7, 8, and 10. – Steven M. Vascellaro Dec 21 '17 at 19:02
  • Is the NAS server configurable, like Linux with Samba? – harrymc Dec 21 '17 at 21:02
  • 2
    I just tried mapping a drive from an XP Pro box to the root of a Win 2008 Server as described by the OP. It did not work. (I have Admin rights on both systems.) Further, it doesn't make sense to map a drive to the "root" of a server. Mapped drives have always terminated at a share! – Twisty Impersonator Dec 22 '17 at 17:03
5
+25

(Possibly partial answer here.) This isn't possible from any version of Windows (including XP) to other Microsoft-based servers. I suspect this may be the case for other OSes hosting SMB shares as well, but I don't have a way to confirm that.

From a machine running Windows XP Professional 32-bit, I attempted to map a drive to a machine running Windows Server 2008 R2 named FSDC-SERVER27. I was logged on to the XP machine with an account that has Administrative rights on both the local and remote computers. As shown here I was unable to map a drive to the so-called "root" of the server:

enter image description here

But this is not unexpected. Mapped drives in Windows have always terminated at a share.

Consider this: If it were possible to map a drive to the root of a server, there would be settings exposed to configure permissions for the "root" share. No such settings exist (at least in Windows). Indeed, all settings for controlling access to and the behavior of shares exist on the share definition itself.

Therefore I conclude it's not possible to map a drive in Windows to the "root" of a server.


On Windows machines, the closest one gets to mapping to the "root" of a server is to map to the root of a specific volume. For example, on non-home editions of Windows, the automatically-generated shares known as Administrative shares include shares of the root of all fixed disk volumes (e.g. C$, E$, etc.). It's also possible on all versions of Windows to manually create a share of the root of a specific volume.

  • As you've pointed out this is impossible, and the user is mistaken about their current share. I suggest they check the current share mount point via net use in a command prompt to see what they have actually got. – djsmiley2k Dec 27 '17 at 13:57
2

\\hostname is not actually a valid "share". You need something after the host in order to map it.

2

The NAS server is most likely running Linux with Samba.

You will need to define a new share which points to the root of the server, which in Linux is /. A better share may be to the folder containing the sub-folders of music, photo, and video, whose location you will need to find.

Configuring Samba is done by editing the file smb.conf. You could append to it, for example (there may be slight changes depending on the NAS operating system version) :

[root-share-name]
path = /
browsable = yes
read only = yes
force user = nobody

You will need to restart Samba for this to take effect, which (depending on the NAS Linux version) may be this command:

sudo service smbd restart

Or you may just reboot the NAS.

If you need more information about configuring Samba, you could easily find it on the Internet once you know the NAS Linux version.

1

This is not direct answer, but what helped me to address the issue when the one would like to easily access all the fileshares on a server, but can't or does not want to type/remember server name or create multiple individual drives for each subfolder.

Step 1: Create a shortcut anywhere: Right click Desktop → Create shortcut (for example)

Step 2: Open a File Explorer window and drag the newly created shortcut to favorites section.

Note: In newer versions of Windows (eg. Windows 10), you can right-click on the newly created Shortcut on your desktop and choose 'Pin to Quick Access'

Windows Favorites/Quick Access Screenshot

While it isn't exactly a mapped drive, you do get a place where all your shares are easily accessible.

This solved what I wanted, and when I searched for an answer, this topic popped up in google first which is why I decided to put the answer here.

Works in Windows 7, Vista, 8 with classic shell, etc

0

Add a new share to the server (i.e.: root) that contains all the other shares as subfolders/links. Then you'll be able to map a drive letter to it.

  • HI, Sure, I understand that would kind of work but: a) this would mess up my built-in share structure (movie, photo, video) that the NAS software requires b) this still doesn't explain how come it's possible in XP and not in Vista – Andy T Jul 28 '10 at 21:39
  • Have you tried \\host\c$ – Mâtt Frëëman Jan 16 '11 at 12:08
0

I have been able to automount distinctive sub directories in Samba shares on my computer at login by using the terminal. The question and accepted answer can be found here. Read it to get details around my answer.

In short what I am suggesting you to do is open a command shell and make a link to the share by entering the following line in cmd or powershell: mklink /d C:\path\to\your\directory \\Server\path\to\share. Note that for powershell you will have to insert at the beginning of the command cmd /c

This solution requires that your username and password are the same on the NAS as for the login on your personal computer. You might be able to specify username and password, but I have no idea how to do this.

-1

Using a File Manager may help?

Servant Salamander (shareware) has a "Change Directory" command (Shift+F7) that allows you to enter something like: \\NAS which does take me to the root of the NAS. (I cannot confirm that this works on W7 at this time, cause the NAS is on an XP system, though it does work on XP & I seem to recall it working on W7.)

(Additionally Salamander can see the Windows Network links so something like \\NAS\MUSIC or \\NAS\VIDEO are available.)

(I named my Buffalo NAS, "NAS".)

"Altap Salamander" http://www.altap.cz/salam_en/index.html

  • You can enter \\server into Windows Explorer too and see all shared resources on the server. But the question is about mapping a drive to the root--a totally different proposition. – Twisty Impersonator Dec 27 '17 at 23:12
-5

It works for me:

\\\host\data

Enter the user credentials in the next window. Share data is some kind of root in the Netgear ReadyNAS.

  • This is not a legitimate attempt to answer the question. – Twisty Impersonator Dec 27 '17 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.