1

I run windows 10 version 20H2 build 19042 and use VMWare Workstation version 16.2.1 as a hosted hypervisor. I installed WSL on one of the VMs and activated nested virtualization. It was perfectly working until I installed WSL on my host. I got the below error when trying to power on the VM:

Virtualized Intel VT-x/EPT is not supported on this platform. Continue without virtualized Intel VT-x/EPT?s Both Yes and No answers couldn't help powering on the VM.

Then I uninstalled WSL on the host and disabled "Windows Subsystem for Linux" from windows features list, but still got the same error.

I am only able to power on the VM if I untick "Virtualize Intel- VT-x or AMD-V/RVI" in VM CPU setting which is not the case, because I need nested virtualization in the VM. Could anyone please help me solving this issue?

9
  • Can you provide a screenshot of the error? We also need to know what version of VMWare Workstation you are running. Have you considered installing the 21H2 enablement package? 2004 was released more than a year ago and is reaching the end of its support. I can’t recall if 2004 is new enough to support VMWare Workstation and the windows feature required for WSL2
    – Ramhound
    Dec 8, 2021 at 16:16
  • @Ramhound VMware version is 16.2.1 which I just updated today hoping that Microsoft virtualization and VMWare get compatibility. For windows I run version 20H2. What I don't understand is that, why after disabling WSL feature on the windows host, it doesn't revert completely to the status at which that VMWare could- use nested virtualization.
    – Yasi
    Dec 8, 2021 at 17:11
  • What optional features do you have enabled currently? You should edit your question instead of submitting a comment.
    – Ramhound
    Dec 8, 2021 at 17:16
  • I updated the post. Not sure if the answer of the last question should be also in the post. Virtual Machine Platform, Windows Hypervisor Platform are enable.
    – Yasi
    Dec 8, 2021 at 17:28
  • You should uninstall them, Windows Hypervisor Platform is required for WSL2, and for little else.
    – Ramhound
    Dec 8, 2021 at 17:37

1 Answer 1

2

Try disabling hyper-v virtualization through bcdedit.

You will probably not be able to do both WSL2 and VMWare stuff at the same time.

EDIT: Mr. @Ramhound had this to say (and he is almost never wrong)

VMWare and Hyper-V should be able to coexist on the same system, certainly, the version of VMWare should allow it.

Do you REALLY NEED WSL2 vs WSL1? WSL1 doesn't require virtualization. I myself use WSL1 and the ONLY THING that it can't do for me is mount other file systems or run kernel mode stuff like docker. The I/O is also a little slow (but mostly unnoticeable).

Search google for "disable virtualization bcdedit".

I myself use the boot menu that allows me to turn it on or off at boot time. You will find that in your search if that is what you seek.

I use VirtualBox and some of the microsoft virtualization technologies and they don't like each other so I need the ability to turn it on or off.

I hope this solves your problem.

4
  • 2
    Fully agree that WSL1 is very often a completely workable (and great) alternative to WSL2. For those who want to follow this path, however, note that you should not follow the "normal" WSL installation process (nor the Microsoft Store Preview). Use the Manual Installation instructions instead, and just perform steps 1 and 6. Dec 8, 2021 at 17:09
  • Nice advice @NotTheDr01ds .. thanks for the addition. Dec 8, 2021 at 17:12
  • 2
    Thank you. I needed WSL for docker. Now I just want to revert this changes because I don't need wsl on my host and I installed it for learning purpose.
    – Yasi
    Dec 8, 2021 at 17:33
  • 1
    @Yasi Yup, that's one good reason for requiring WSL2. ;-) Dec 8, 2021 at 17:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .